summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2019-01-31 19:35:47 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2019-01-31 21:18:55 -0500
commit276cc53b25ebb40e198920b71699361051fdc712 (patch)
treeae7ddc4d2a9e410d977591e5b4494e06fd5969de /app-crypt
parentdev-python/pytest: bump to 4.2.0 (diff)
downloadgentoo-276cc53b25ebb40e198920b71699361051fdc712.tar.gz
gentoo-276cc53b25ebb40e198920b71699361051fdc712.tar.bz2
gentoo-276cc53b25ebb40e198920b71699361051fdc712.zip
app-crypt/yubikey-manager: bump to 2.0.0 #674050
Closes: https://bugs.gentoo.org/674050 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/yubikey-manager/Manifest1
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-2.0.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/Manifest b/app-crypt/yubikey-manager/Manifest
index c6c6e839a6f7..e37874c44630 100644
--- a/app-crypt/yubikey-manager/Manifest
+++ b/app-crypt/yubikey-manager/Manifest
@@ -7,3 +7,4 @@ DIST yubikey-manager-0.7.0.tar.gz 83385 BLAKE2B cd0c440f8ce81549e52dd8e546d82678
DIST yubikey-manager-0.7.1-test-files.tar.xz 9756 BLAKE2B 5a2e2a2a58d04c8f9954c1d13d0892b4f7392785d6e83e6948e720606318860b93e70862cee0ee7f987c14c3fa49bb7ff20cdf2a5bfc09c1f08681346428c003 SHA512 7543a9e9cfbe7f9ec02c98397f5cbd77cb307d79985a4b060176ee26605767e74d8b18d4c036ff90aed9a0232bb1382908c75e876a911c2ceb35a12666699b94
DIST yubikey-manager-0.7.1.tar.gz 71834 BLAKE2B 45b0366531c8a158b3d8ebcfa8b76d608c14dba02224d4e4962c3757446829e3dff5f5e0d0ceda67caab7c67ad0510e037770c58a50552c2c6971136cb75c806 SHA512 3e9105f1c033f9314b90cf209eb52f7879fa1ea69e9ae6dac8de0b24d7d2ff6e45b6dd530917535fa645d6eea461f5b4f23bb8deb103ffc27d1f3483cfa681c7
DIST yubikey-manager-1.0.0.tar.gz 90653 BLAKE2B 5d8522181ad460521995d3cae63976e06a444816a24efdc83b526d50262c902c8cc76b29d43f6f07725ee714666c853b690f1dd6fe98c9409f0cc1e722ada6f5 SHA512 9fd1926bf4e2c1278a42136a05db3e5fe0b7cb3d740f601fd0a420ab851badb61c2dd165157ac5b1f47e934f771b9d0b3cca4e07d1772d0f743556d482f77c11
+DIST yubikey-manager-2.0.0.tar.gz 102078 BLAKE2B a2b8f90dabefb1014881cbe709222bf5cb48c9f409b415a8a2b27d7101c2da6189d0ebfe21a2701d10798c48c44e546659f9424ba6bf9257f7311abb0fc90b9b SHA512 42bebb88ba78bcce00a228109d0b4c815b3242ddbe43fd26c1209ba8666eb033ab77d5acd39a157e8310ce327de8d38bf88cfa0ffaed6273236b220c39e72e3b
diff --git a/app-crypt/yubikey-manager/yubikey-manager-2.0.0.ebuild b/app-crypt/yubikey-manager/yubikey-manager-2.0.0.ebuild
new file mode 100644
index 000000000000..7fa00f1c34db
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-2.0.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit readme.gentoo-r1 distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+SRC_URI="https://github.com/Yubico/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}" # <- need this only for github-based SRC_URI
+# Here's the alternative SRC_URI, though tarball contents may differ
+# See: https://github.com/Yubico/yubikey-manager/issues/217
+# SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ dev-python/fido2[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=sys-auth/ykpers-1.19.0
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2_7')
+ )
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOC_CONTENTS
+
+ distutils-r1_python_install_all
+
+ DOC_CONTENTS="
+ The 'openpgp' command may require the package 'app-crypt/ccid'
+ to be installed on the system. Furthermore, make sure that pcscd
+ daemon is running and has correct access permissions to USB
+ devices.
+ "
+ readme.gentoo_create_doc
+
+ doman "${S}"/man/ykman.1
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}