summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-09-07 17:20:04 +0200
committerDavid Seifert <soap@gentoo.org>2021-09-07 17:20:04 +0200
commit358af1feef453a02aa73ef5c281fe509bcb6ffde (patch)
treeae91268b7926765da7d4b21752c7c68e1140047d /app-crypt
parentapp-crypt/gnupg: remove unused patch (diff)
downloadgentoo-358af1feef453a02aa73ef5c281fe509bcb6ffde.tar.gz
gentoo-358af1feef453a02aa73ef5c281fe509bcb6ffde.tar.bz2
gentoo-358af1feef453a02aa73ef5c281fe509bcb6ffde.zip
app-crypt/gnupg: fix USE=tofu
Bug: https://dev.gnupg.org/T5588 Acked-by: Mikle Kolyada <zlogene@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/files/gnupg-2.3.0-sqlite_check.patch62
-rw-r--r--app-crypt/gnupg/gnupg-2.3.2.ebuild17
2 files changed, 6 insertions, 73 deletions
diff --git a/app-crypt/gnupg/files/gnupg-2.3.0-sqlite_check.patch b/app-crypt/gnupg/files/gnupg-2.3.0-sqlite_check.patch
deleted file mode 100644
index dd529da7a7c6..000000000000
--- a/app-crypt/gnupg/files/gnupg-2.3.0-sqlite_check.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From 58aa0e8547a29e147f3d9d1792117d96bc00ffda Mon Sep 17 00:00:00 2001
-From: Lars Wendler <polynomial-c@gentoo.org>
-Date: Thu, 8 Apr 2021 11:05:36 +0200
-Subject: [PATCH] gnupg: configure.ac: Fix sqlite3 detection
-
-or else --disable-sqlite has no effect and linking later fails with:
-
- keyboxd-backend-sqlite.o: in function `show_sqlstmt.part.0':
- backend-sqlite.c:(.text+0x42): undefined reference to `sqlite3_expanded_sql'
-
-Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
----
- configure.ac | 23 ++++++++++++-----------
- 1 file changed, 12 insertions(+), 11 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 9cf0c6a7f..d46469cbb 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -969,18 +969,20 @@ AC_ARG_ENABLE(sqlite,
- [disable the use of SQLITE]),
- try_sqlite=$enableval, try_sqlite=yes)
-
--if test x"$use_tofu" = xyes ; then
-- if test x"$try_sqlite" = xyes ; then
-+AS_IF([test x"$try_sqlite" = xyes], [
- PKG_CHECK_MODULES([SQLITE3], [sqlite3 >= $NEED_SQLITE_VERSION],
- [have_sqlite=yes],
- [have_sqlite=no])
-- fi
-- if test "$have_sqlite" = "yes"; then
-- :
-- AC_SUBST([SQLITE3_CFLAGS])
-- AC_SUBST([SQLITE3_LIBS])
-- else
-- use_tofu=no
-+ AS_IF([test "$have_sqlite" = "yes"], [
-+ AC_SUBST([SQLITE3_CFLAGS])
-+ AC_SUBST([SQLITE3_LIBS])
-+ ])
-+ ])
-+
-+AS_IF([test "$have_sqlite" != "yes"], [
-+ AS_IF([test x"$use_tofu" = xyes], [
-+ use_tofu=no
-+ ])
- build_keyboxd=no
- tmp=$(echo "$SQLITE3_PKG_ERRORS" | tr '\n' '\v' | sed 's/\v/\n*** /g')
- AC_MSG_WARN([[
-@@ -988,8 +990,7 @@ if test x"$use_tofu" = xyes ; then
- *** Building without SQLite support - TOFU and Keyboxd disabled
- ***
- *** $tmp]])
-- fi
--fi
-+])
-
- AM_CONDITIONAL(SQLITE3, test "$have_sqlite" = "yes")
-
---
-2.31.1
-
diff --git a/app-crypt/gnupg/gnupg-2.3.2.ebuild b/app-crypt/gnupg/gnupg-2.3.2.ebuild
index 3576669b399e..9e1c1de7266c 100644
--- a/app-crypt/gnupg/gnupg-2.3.2.ebuild
+++ b/app-crypt/gnupg/gnupg-2.3.2.ebuild
@@ -3,18 +3,19 @@
EAPI=8
-inherit autotools flag-o-matic systemd toolchain-funcs
+inherit flag-o-matic systemd toolchain-funcs
MY_P="${P/_/-}"
DESCRIPTION="The GNU Privacy Guard, a GPL OpenPGP implementation"
HOMEPAGE="https://gnupg.org/"
SRC_URI="mirror://gnupg/gnupg/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bzip2 doc ldap nls readline selinux +smartcard sqlite ssl tofu tools usb user-socket wks-server"
+IUSE="bzip2 doc ldap nls readline selinux +smartcard ssl tofu tools usb user-socket wks-server"
# Existence of executables is checked during configuration.
DEPEND=">=dev-libs/libassuan-2.5.0
@@ -27,7 +28,7 @@ DEPEND=">=dev-libs/libassuan-2.5.0
ldap? ( net-nds/openldap )
readline? ( sys-libs/readline:0= )
smartcard? ( usb? ( virtual/libusb:1 ) )
- sqlite? ( >=dev-db/sqlite-3.27 )
+ tofu? ( >=dev-db/sqlite-3.27 )
ssl? ( >=net-libs/gnutls-3.0:0= )
sys-libs/zlib
"
@@ -42,10 +43,6 @@ BDEPEND="virtual/pkgconfig
doc? ( sys-apps/texinfo )
nls? ( sys-devel/gettext )"
-S="${WORKDIR}/${MY_P}"
-
-REQUIRED_USE="tofu? ( sqlite )"
-
DOCS=(
ChangeLog NEWS README THANKS TODO VERSION
doc/FAQ doc/DETAILS doc/HACKING doc/TRANSLATE doc/OpenPGP doc/KEYSERVER
@@ -53,14 +50,11 @@ DOCS=(
PATCHES=(
"${FILESDIR}/${PN}-2.1.20-gpgscm-Use-shorter-socket-path-lengts-to-improve-tes.patch"
- "${FILESDIR}/${PN}-2.3.0-sqlite_check.patch"
)
src_prepare() {
default
- eautoreconf
-
# Inject SSH_AUTH_SOCK into user's sessions after enabling gpg-agent-ssh.socket in systemctl --user mode,
# idea borrowed from libdbus, see
# https://gitlab.freedesktop.org/dbus/dbus/-/blob/master/bus/systemd-user/dbus.socket.in#L6
@@ -76,9 +70,10 @@ src_configure() {
$(use_enable bzip2)
$(use_enable nls)
$(use_enable smartcard scdaemon)
- $(use_enable sqlite)
$(use_enable ssl gnutls)
$(use_enable tofu)
+ $(use_enable tofu keyboxd)
+ $(use_enable tofu sqlite)
$(use smartcard && use_enable usb ccid-driver || echo '--disable-ccid-driver')
$(use_enable wks-server wks-tools)
$(use_with ldap)