summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-01-07 13:04:00 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-01-07 13:05:18 -0600
commit8f2df3462abcc8e42aa243ae012edb2c21b011aa (patch)
tree80e5ed726ac6a29186334a633cf5076d1f0af7c1 /app-crypt
parentapp-crypt/certbot: 0.30.0 bump (diff)
downloadgentoo-8f2df3462abcc8e42aa243ae012edb2c21b011aa.tar.gz
gentoo-8f2df3462abcc8e42aa243ae012edb2c21b011aa.tar.bz2
gentoo-8f2df3462abcc8e42aa243ae012edb2c21b011aa.zip
app-crypt/certbot-apache: 0.30.0 bump
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot-apache/Manifest1
-rw-r--r--app-crypt/certbot-apache/certbot-apache-0.30.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index 227c09874943..c2562fa91583 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1,2 +1,3 @@
DIST certbot-0.28.0.tar.gz 1253582 BLAKE2B f97a195afacd279b1dfc2d62ea45ae43dfd2d160f148200dd0756eda1c75561a6b1326a346f84c666c8409d339bc4341106ed4cfc684a7d868b6e1e10707ef78 SHA512 07c9bbad52acebc60e48d79619e4f12818d67c3b0f41ffa4fcd02098fb9da245e4006418f54c51c2e4bb9aaa01a21f7a083c9eb092f533e6676ed75ae8667a54
DIST certbot-0.29.1.tar.gz 1265252 BLAKE2B dcb63862f427851655ae8282a3d479adc4aa2f553f510f3769d59748728505cb052291f728f1a01ad4efffa25d9aee6be881a9a7178fb0c025725780150ade45 SHA512 c9b976bec51c83412816726b709b79af0b464efa02f67c4ce7e754a2e6fa11e6811ca5db66616bd7b9e7920d6613665d3e58998c891bdb1452a5159a91971c56
+DIST certbot-0.30.0.tar.gz 1266974 BLAKE2B f6c0c6864297ba0f6fc3232e0655d79e0b045923c22015d34f706e392ef83ca95c19b36d47120500bf4a0561a277aced13f7fb49d7bdcdc8359113c617dca37c SHA512 85095dd75ce639fcf93d748e2d32a686aecfa9002ccb2c23bdd4e33f1c47268386a86befbcca8180acf48881888fad484f485ad03fc7acef21a308c4d5432ac5
diff --git a/app-crypt/certbot-apache/certbot-apache-0.30.0.ebuild b/app-crypt/certbot-apache/certbot-apache-0.30.0.ebuild
new file mode 100644
index 000000000000..9a6423344f6a
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-0.30.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=app-crypt/certbot-0.26.0[${PYTHON_USEDEP}]
+ >=app-crypt/acme-0.25.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests || die
+}