summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2019-04-19 23:30:59 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2019-04-19 23:31:12 -0700
commit90e7773e6be8589673a15b63d057c45cf738432b (patch)
tree650cb94868e0762b7c9298d1ab49fdc07c7a5307 /app-crypt
parentmedia-libs/libsoundio: version bump to 2.0.0 (diff)
downloadgentoo-90e7773e6be8589673a15b63d057c45cf738432b.tar.gz
gentoo-90e7773e6be8589673a15b63d057c45cf738432b.tar.bz2
gentoo-90e7773e6be8589673a15b63d057c45cf738432b.zip
app-crypt/acmebot: new package, LetsEncrypt automation client
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acmebot/Manifest1
-rw-r--r--app-crypt/acmebot/acmebot-2.3.0.ebuild44
-rw-r--r--app-crypt/acmebot/acmebot-9999.ebuild44
-rw-r--r--app-crypt/acmebot/metadata.xml7
4 files changed, 96 insertions, 0 deletions
diff --git a/app-crypt/acmebot/Manifest b/app-crypt/acmebot/Manifest
new file mode 100644
index 000000000000..4b55640b4b68
--- /dev/null
+++ b/app-crypt/acmebot/Manifest
@@ -0,0 +1 @@
+DIST acmebot-2.3.0.tar.gz 64841 BLAKE2B 92bfb9a58722b9955fe908e2fcb1a3ee593bf87e3fdf3dc9564bcbe291b13c553ad426673c337a59344287da64c4ee5cffc734f8dfb60447f96d6234814f0167 SHA512 3951cc7138eb0b83bd802a2e0a221fa985209ba276028606d887b7d2eff84c35db034f4a3d8a6836b3ac149c6dbfa27b1ea47e864f549f8d88b758b40407c4f4
diff --git a/app-crypt/acmebot/acmebot-2.3.0.ebuild b/app-crypt/acmebot/acmebot-2.3.0.ebuild
new file mode 100644
index 000000000000..efcd7603271c
--- /dev/null
+++ b/app-crypt/acmebot/acmebot-2.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python3_{4..6})
+EGIT_REPO_URI="https://github.com/plinss/${PN}.git"
+[[ $PV == 9999 ]] && _scm=git-r3
+
+inherit ${_scm} python-r1
+
+DESCRIPTION="Certificate manager bot using ACME protocol"
+HOMEPAGE="https://github.com/plinss/acmebot"
+if [[ $PV != 9999 ]]; then
+ SRC_URI="https://github.com/plinss/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ $PV != 9999 ]] && KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="
+ >=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.8[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pydns-3.1.0:3[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.1.4[${PYTHON_USEDEP}]
+ >=dev-python/asn1crypto-0.24.0[${PYTHON_USEDEP}]
+ >=dev-python/acme-0.25.1[${PYTHON_USEDEP}]
+ "
+RDEPEND="${CDEPEND}"
+DEPEND=""
+
+src_install() {
+ dobin acmebot
+ python_replicate_script "${ED}"/usr/bin/acmebot
+ insinto /etc/logrotate.d
+ doins logrotate.d/acmebot
+ insinto /etc/acmebot
+ doins acmebot.example.json
+ dodoc README.rst
+}
diff --git a/app-crypt/acmebot/acmebot-9999.ebuild b/app-crypt/acmebot/acmebot-9999.ebuild
new file mode 100644
index 000000000000..efcd7603271c
--- /dev/null
+++ b/app-crypt/acmebot/acmebot-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python3_{4..6})
+EGIT_REPO_URI="https://github.com/plinss/${PN}.git"
+[[ $PV == 9999 ]] && _scm=git-r3
+
+inherit ${_scm} python-r1
+
+DESCRIPTION="Certificate manager bot using ACME protocol"
+HOMEPAGE="https://github.com/plinss/acmebot"
+if [[ $PV != 9999 ]]; then
+ SRC_URI="https://github.com/plinss/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ $PV != 9999 ]] && KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="
+ >=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.8[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pydns-3.1.0:3[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.1.4[${PYTHON_USEDEP}]
+ >=dev-python/asn1crypto-0.24.0[${PYTHON_USEDEP}]
+ >=dev-python/acme-0.25.1[${PYTHON_USEDEP}]
+ "
+RDEPEND="${CDEPEND}"
+DEPEND=""
+
+src_install() {
+ dobin acmebot
+ python_replicate_script "${ED}"/usr/bin/acmebot
+ insinto /etc/logrotate.d
+ doins logrotate.d/acmebot
+ insinto /etc/acmebot
+ doins acmebot.example.json
+ dodoc README.rst
+}
diff --git a/app-crypt/acmebot/metadata.xml b/app-crypt/acmebot/metadata.xml
new file mode 100644
index 000000000000..79d462e85571
--- /dev/null
+++ b/app-crypt/acmebot/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>