summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2018-11-10 18:54:57 +0100
committerHanno <hanno@gentoo.org>2018-11-10 18:54:57 +0100
commit9f177a3055b06a3bf070ca91da8520d3ac71d4eb (patch)
tree53156b0b977aefbf51804d40e51647934a5d58e3 /app-crypt
parentx11-misc/xorg-cf-files-1.0.6-r1: alpha stable, bug 668900 (diff)
downloadgentoo-9f177a3055b06a3bf070ca91da8520d3ac71d4eb.tar.gz
gentoo-9f177a3055b06a3bf070ca91da8520d3ac71d4eb.tar.bz2
gentoo-9f177a3055b06a3bf070ca91da8520d3ac71d4eb.zip
app-crypt/md4sum: EAPI 7, HTTPS links, cleanup.
Closes: https://github.com/gentoo/gentoo/pull/9030 Closes: https://bugs.gentoo.org/663038 Signed-off-by: Hanno Boeck <hanno@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.12
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/md4sum/md4sum-0.02.03-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/md4sum/md4sum-0.02.03-r2.ebuild b/app-crypt/md4sum/md4sum-0.02.03-r2.ebuild
new file mode 100644
index 000000000000..8198a1631ad6
--- /dev/null
+++ b/app-crypt/md4sum/md4sum-0.02.03-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="md4 and edonkey hash algorithm tool"
+HOMEPAGE="https://linux.xulin.de/c/"
+SRC_URI="https://linux.xulin.de/c/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=( "${FILESDIR}"/md4sum-fix-out-of-bounds-write.diff )
+
+src_prepare() {
+ default
+ sed -i -e "s:CFLAGS=:CFLAGS=${CFLAGS} :g" \
+ -e "s:install -s:install:g" Makefile.Linux || die
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}