summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-12 15:38:20 +0100
committerSam James <sam@gentoo.org>2022-06-12 15:51:45 +0100
commitf91c0e85e6e08c02a0bdc7dd62731a80a3b84c5c (patch)
treed69aa6dd07de8a4403b9244c6bc139c84fafd6bd /app-crypt
parentdev-python/pydevd: fix distutils-r1 usage (diff)
downloadgentoo-f91c0e85e6e08c02a0bdc7dd62731a80a3b84c5c.tar.gz
gentoo-f91c0e85e6e08c02a0bdc7dd62731a80a3b84c5c.tar.bz2
gentoo-f91c0e85e6e08c02a0bdc7dd62731a80a3b84c5c.zip
app-crypt/gpgme: fix distutils-r1 use
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gpgme/gpgme-1.17.1-r1.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/app-crypt/gpgme/gpgme-1.17.1-r1.ebuild b/app-crypt/gpgme/gpgme-1.17.1-r1.ebuild
index 545d22dc9141..db83c2548bf2 100644
--- a/app-crypt/gpgme/gpgme-1.17.1-r1.ebuild
+++ b/app-crypt/gpgme/gpgme-1.17.1-r1.ebuild
@@ -102,15 +102,14 @@ src_compile() {
src_test() {
default
- if use python; then
- test_python() {
- emake -C lang/python/tests check \
- PYTHON=${EPYTHON} \
- PYTHONS=${EPYTHON} \
- TESTFLAGS="--python-libdir=${BUILD_DIR}/lib"
- }
- python_foreach_impl test_python
- fi
+ use python && distutils-r1_src_test
+}
+
+python_test() {
+ emake -C lang/python/tests check \
+ PYTHON=${EPYTHON} \
+ PYTHONS=${EPYTHON} \
+ TESTFLAGS="--python-libdir=${BUILD_DIR}/lib"
}
src_install() {