summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-doc/casting-spels-emacs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-doc/casting-spels-emacs')
-rw-r--r--app-doc/casting-spels-emacs/Manifest1
-rw-r--r--app-doc/casting-spels-emacs/casting-spels-emacs-19-r1.ebuild36
-rw-r--r--app-doc/casting-spels-emacs/files/casting-spels-emacs-19-require-cl.patch11
-rw-r--r--app-doc/casting-spels-emacs/metadata.xml15
4 files changed, 63 insertions, 0 deletions
diff --git a/app-doc/casting-spels-emacs/Manifest b/app-doc/casting-spels-emacs/Manifest
new file mode 100644
index 000000000000..00c0cc6dd5e2
--- /dev/null
+++ b/app-doc/casting-spels-emacs/Manifest
@@ -0,0 +1 @@
+DIST casting-spels-emacs-v19.zip 1883707 SHA256 aa2e33449375db66577f80b7246ece75e75b04dc6f97fbc8ca9365579db16f3a SHA512 349d326a4787b1f1f7dd0630012f938fc67f354f3cb8f18a8b501dff3c1f0e7f07decea528a55f38e1f83d222c917455102103732560a426f37fb183e27d24ab WHIRLPOOL 032929e1e1a6e95c99ae730c41ac16f7264c1682ba778b133d82dcccabe46fa4bd5514efb549535d3cf831a6a2f76ba16b546b4a52b91df6c38d82a36c491420
diff --git a/app-doc/casting-spels-emacs/casting-spels-emacs-19-r1.ebuild b/app-doc/casting-spels-emacs/casting-spels-emacs-19-r1.ebuild
new file mode 100644
index 000000000000..b82941cbb7f8
--- /dev/null
+++ b/app-doc/casting-spels-emacs/casting-spels-emacs-19-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit elisp-common eutils
+
+DESCRIPTION="Casting SPELs in Lisp - A Comic Book (Emacs Lisp Edition)"
+HOMEPAGE="http://code.google.com/p/casting-spels-emacs/"
+SRC_URI="http://casting-spels-emacs.googlecode.com/files/${PN}-v${PV}.zip"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="virtual/emacs"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ edos2unix *.txt html/*.html {lisp,test}/*.el
+
+ # needs cl extensions
+ epatch "${FILESDIR}/${P}-require-cl.patch"
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.el || die
+ dohtml -r html/. images || die
+ dosym html/images /usr/share/doc/${PF}/images
+ dosym ${SITELISP}/${PN} /usr/share/doc/${PF}/lisp
+ dodoc README.txt test/walk-through-commands.el
+}
diff --git a/app-doc/casting-spels-emacs/files/casting-spels-emacs-19-require-cl.patch b/app-doc/casting-spels-emacs/files/casting-spels-emacs-19-require-cl.patch
new file mode 100644
index 000000000000..d7743d29fbf6
--- /dev/null
+++ b/app-doc/casting-spels-emacs/files/casting-spels-emacs-19-require-cl.patch
@@ -0,0 +1,11 @@
+--- casting-spels-emacs-orig/lisp/wizard-adventure-emacs.el 2007-09-17 04:18:48.000000000 +0200
++++ casting-spels-emacs/lisp/wizard-adventure-emacs.el 2008-09-05 19:59:21.000000000 +0200
+@@ -27,6 +27,8 @@
+
+ ;;; Code in the comic not needed to play the game is commented out...
+
++(require 'cl)
++
+ (setq eval-expression-print-length nil)
+
+ (setq objects '(whiskey-bottle bucket frog chain))
diff --git a/app-doc/casting-spels-emacs/metadata.xml b/app-doc/casting-spels-emacs/metadata.xml
new file mode 100644
index 000000000000..b81c3b2a076a
--- /dev/null
+++ b/app-doc/casting-spels-emacs/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ Ever wonder what makes Lisp so powerful? Now you can find out for yourself -
+ And you can do it right inside your GNU Emacs text editor! If you've spent
+ any time working with Emacs, you'll find out that in order to get the full
+ power out of this uber text editor, you'll want to learn a little about
+ programming in Emacs Lisp. Anyone who has ever learned to program in Lisp
+ will tell you it is very different from any other programming language.
+ It is different in lots of surprising ways - This comic book will let you
+ find out how Lisp's unique design makes it so powerful!
+</longdescription>
+</pkgmetadata>