summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorneeshy <neeshy@tfwno.gf>2020-03-28 16:06:52 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-04-05 10:17:54 +0300
commit7f629a139b3531f94e5099d9fbc8014010d01dae (patch)
tree57151a3fd561184f0616e63ef82ac9dae457865a /app-doc
parentapp-doc/cppman: bump version to 0.4.9 (diff)
downloadgentoo-7f629a139b3531f94e5099d9fbc8014010d01dae.tar.gz
gentoo-7f629a139b3531f94e5099d9fbc8014010d01dae.tar.bz2
gentoo-7f629a139b3531f94e5099d9fbc8014010d01dae.zip
app-doc/cppman: cleanup, fix DOCS location
Signed-off-by: Nima Sadeghi <neeshy@tfwno.gf> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/cppman/cppman-0.4.8-r2.ebuild (renamed from app-doc/cppman/cppman-0.4.8-r1.ebuild)24
-rw-r--r--app-doc/cppman/cppman-0.4.9.ebuild20
2 files changed, 30 insertions, 14 deletions
diff --git a/app-doc/cppman/cppman-0.4.8-r1.ebuild b/app-doc/cppman/cppman-0.4.8-r2.ebuild
index 931aff72c2bd..47193572aa46 100644
--- a/app-doc/cppman/cppman-0.4.8-r1.ebuild
+++ b/app-doc/cppman/cppman-0.4.8-r2.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="sqlite,threads"
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite,threads(+)"
DISTUTILS_SINGLE_IMPL=true
+DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
DESCRIPTION="C++ man pages for Linux, with source from cplusplus.com and cppreference.com"
HOMEPAGE="https://github.com/aitjcize/cppman"
-LICENSE="GPL-3"
-
-SLOT="0"
SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="bash-completion zsh-completion"
RDEPEND="
sys-apps/groff
@@ -27,5 +28,12 @@ RDEPEND="
')
"
-# `./setup install` already installs docs
-DOCS=()
+DOCS=( README.rst AUTHORS COPYING ChangeLog )
+
+src_prepare() {
+ sed -i '\:share/doc/cppman:d' setup.py
+ use bash-completion || sed -i '\:share/bash-completion/completions:d' setup.py
+ use zsh-completion || sed -i '\:share/zsh-completion/completions:d' setup.py
+
+ default
+}
diff --git a/app-doc/cppman/cppman-0.4.9.ebuild b/app-doc/cppman/cppman-0.4.9.ebuild
index a124e60ffdd5..47193572aa46 100644
--- a/app-doc/cppman/cppman-0.4.9.ebuild
+++ b/app-doc/cppman/cppman-0.4.9.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="sqlite,threads(+)"
DISTUTILS_SINGLE_IMPL=true
+DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
DESCRIPTION="C++ man pages for Linux, with source from cplusplus.com and cppreference.com"
HOMEPAGE="https://github.com/aitjcize/cppman"
-LICENSE="GPL-3"
-
-SLOT="0"
SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="bash-completion zsh-completion"
RDEPEND="
sys-apps/groff
@@ -27,5 +28,12 @@ RDEPEND="
')
"
-# `./setup install` already installs docs
-DOCS=()
+DOCS=( README.rst AUTHORS COPYING ChangeLog )
+
+src_prepare() {
+ sed -i '\:share/doc/cppman:d' setup.py
+ use bash-completion || sed -i '\:share/bash-completion/completions:d' setup.py
+ use zsh-completion || sed -i '\:share/zsh-completion/completions:d' setup.py
+
+ default
+}