summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-03-11 22:25:27 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-03-11 22:29:19 +0000
commit987736474487824feeb7cafea18a783fad668e7b (patch)
tree0e6a4c0db5a42bb656a85f06b9c4eb6ddf34afc8 /app-doc
parentdev-perl/JSON-RPC: Remove old (diff)
downloadgentoo-987736474487824feeb7cafea18a783fad668e7b.tar.gz
gentoo-987736474487824feeb7cafea18a783fad668e7b.tar.bz2
gentoo-987736474487824feeb7cafea18a783fad668e7b.zip
app-doc/diveintopython: Add ebuilds to install the famous "Dive Into Python" ebook.
Package-Manager: portage-2.2.26 Gentoo-Bug: https://bugs.gentoo.org/284506 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/diveintopython/Manifest2
-rw-r--r--app-doc/diveintopython/diveintopython-2.ebuild36
-rw-r--r--app-doc/diveintopython/diveintopython-3.ebuild31
-rw-r--r--app-doc/diveintopython/metadata.xml15
4 files changed, 84 insertions, 0 deletions
diff --git a/app-doc/diveintopython/Manifest b/app-doc/diveintopython/Manifest
new file mode 100644
index 000000000000..3f326702ae4e
--- /dev/null
+++ b/app-doc/diveintopython/Manifest
@@ -0,0 +1,2 @@
+DIST diveintopython-2.zip 865555 SHA256 cf51555500b77c51f6a35c59eaf049b23c8729ef3bef31fc445b6aea45d150a6 SHA512 9c57a9e228d30186b1e6fc10a47d4fa69704fd83ea68bba030d7909ad8df2b9cfeee942caf359b1dd1fd8f9459fee58ea8ddb3813759b17f06b93b3ccf4ca296 WHIRLPOOL 6af00e6d36c8240867b8753478ad749737adffafee2d7641759a1e269981292288b27360f936663716a7cdca5fd1bb27bbdae94b70b497837a6bdda1261cba20
+DIST diveintopython-3.zip 7796744 SHA256 b8708fc035c8272caf3d25e9cfcdb824d2c21ecf1b3c34aba900e0c99dd96a9f SHA512 0d62e85184138f67a21020064bb59805c21ac41b3044e4af3d7de0e92e4c0068a3ec389430dfd5c3bd3e234af6a1079aaa3d2794aabaa3b5ef8d0a26c7c88323 WHIRLPOOL 16484ab0211ec5181acefb2e687436990c71efea94e042bd31a8c75e4eb71e5f64877b7cb02f8ad7d0e57188dc6d25e483c91c84610888030940fd4cf4a9ce6d
diff --git a/app-doc/diveintopython/diveintopython-2.ebuild b/app-doc/diveintopython/diveintopython-2.ebuild
new file mode 100644
index 000000000000..ead1ca4b2619
--- /dev/null
+++ b/app-doc/diveintopython/diveintopython-2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+MY_PV="5.4"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="'Dive Into Python' by Mark Pilgrim - Python 2.x book"
+HOMEPAGE="http://www.diveintopython.net/"
+SRC_URI="http://www.diveintopython.net/download/${PN}-html-${MY_PV}.zip -> ${P}.zip"
+LICENSE="FDL-1.1"
+SLOT="2"
+
+KEYWORDS="~amd64 ~ppc64 ~ppc ~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+}
+
+src_install() {
+ insinto /usr/share/doc/${PN}-${SLOT}
+ doins -r html/*
+ insinto /usr/share/doc/${PN}-${SLOT}/examples
+ doins -r py
+}
diff --git a/app-doc/diveintopython/diveintopython-3.ebuild b/app-doc/diveintopython/diveintopython-3.ebuild
new file mode 100644
index 000000000000..6b44e595a5e7
--- /dev/null
+++ b/app-doc/diveintopython/diveintopython-3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="'Dive Into Python' by Mark Pilgrim - Python 3.x book"
+HOMEPAGE="http://www.diveintopython3.net/"
+SRC_URI="http://dev.gentoo.org/~monsieurp/packages/${P}.zip"
+LICENSE="FDL-1.1"
+SLOT="3"
+
+KEYWORDS="~amd64 ~ppc64 ~ppc ~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}${PV}-master"
+
+src_prepare() {
+ default
+}
+
+src_install() {
+ insinto /usr/share/doc/${PN}-${SLOT}
+ doins -r *
+}
diff --git a/app-doc/diveintopython/metadata.xml b/app-doc/diveintopython/metadata.xml
new file mode 100644
index 000000000000..150f83f5c915
--- /dev/null
+++ b/app-doc/diveintopython/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <longdescription lang="en">
+ Dive Into Python is a free Python book for experienced programmers.
+ </longdescription>
+</pkgmetadata>