summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-11-23 23:21:15 +0100
committerUlrich Müller <ulm@gentoo.org>2019-11-23 23:25:44 +0100
commit452ce7d583c7ca2564c5ec949bb94a7c7b2ea9d2 (patch)
tree53134ffd6365b4a399840858cde86891de3fe5be /app-editors/emacs
parentdev-python/regex: Version bump to 2019.11.1, add py38 (diff)
downloadgentoo-452ce7d583c7ca2564c5ec949bb94a7c7b2ea9d2.tar.gz
gentoo-452ce7d583c7ca2564c5ec949bb94a7c7b2ea9d2.tar.bz2
gentoo-452ce7d583c7ca2564c5ec949bb94a7c7b2ea9d2.zip
app-editors/emacs: Fix order of Info-directory-list.
Some packages like gcc and binutils install their Info files in funny locations outside of /usr/share/info (but still under /usr/share). Adjust the sorting algorithm, in order to keep the current Emacs version above them in the main Info menu. No revision bump because this is mostly a cosmetic change and doesn't affect functionality. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/emacs-23.4-r18.ebuild4
-rw-r--r--app-editors/emacs/emacs-24.5-r7.ebuild4
-rw-r--r--app-editors/emacs/emacs-25.3-r6.ebuild4
-rw-r--r--app-editors/emacs/emacs-26.2.ebuild4
-rw-r--r--app-editors/emacs/emacs-26.3-r1.ebuild4
5 files changed, 10 insertions, 10 deletions
diff --git a/app-editors/emacs/emacs-23.4-r18.ebuild b/app-editors/emacs/emacs-23.4-r18.ebuild
index 7fa200d71b1c..8227d4b3a671 100644
--- a/app-editors/emacs/emacs-23.4-r18.ebuild
+++ b/app-editors/emacs/emacs-23.4-r18.ebuild
@@ -287,9 +287,9 @@ src_install () {
Y "${EPREFIX}${cdir}")
X (let ((path (getenv "INFOPATH"))
X (dir "${EPREFIX}/usr/share/info/${EMACS_SUFFIX}")
- X (re "\\\\\`${EPREFIX}/usr/share/info\\\\>"))
+ X (re "\\\\\`${EPREFIX}/usr/share\\\\>"))
X (and path
- X ;; move Emacs Info dir before anything else in /usr/share/info
+ X ;; move Emacs Info dir before anything else in /usr/share
X (let* ((p (cons nil (split-string path ":" t))) (q p))
X (while (and (cdr q) (not (string-match re (cadr q))))
X (setq q (cdr q)))
diff --git a/app-editors/emacs/emacs-24.5-r7.ebuild b/app-editors/emacs/emacs-24.5-r7.ebuild
index 7a8a310132f8..2c6b9d7dc04a 100644
--- a/app-editors/emacs/emacs-24.5-r7.ebuild
+++ b/app-editors/emacs/emacs-24.5-r7.ebuild
@@ -282,9 +282,9 @@ src_install () {
Y "${EPREFIX}${cdir}")
X (let ((path (getenv "INFOPATH"))
X (dir "${EPREFIX}/usr/share/info/${EMACS_SUFFIX}")
- X (re "\\\\\`${EPREFIX}/usr/share/info\\\\>"))
+ X (re "\\\\\`${EPREFIX}/usr/share\\\\>"))
X (and path
- X ;; move Emacs Info dir before anything else in /usr/share/info
+ X ;; move Emacs Info dir before anything else in /usr/share
X (let* ((p (cons nil (split-string path ":" t))) (q p))
X (while (and (cdr q) (not (string-match re (cadr q))))
X (setq q (cdr q)))
diff --git a/app-editors/emacs/emacs-25.3-r6.ebuild b/app-editors/emacs/emacs-25.3-r6.ebuild
index 8825e18aa7e9..726d3e818c2d 100644
--- a/app-editors/emacs/emacs-25.3-r6.ebuild
+++ b/app-editors/emacs/emacs-25.3-r6.ebuild
@@ -290,9 +290,9 @@ src_install () {
Y "${EPREFIX}${cdir}")
X (let ((path (getenv "INFOPATH"))
X (dir "${EPREFIX}/usr/share/info/${EMACS_SUFFIX}")
- X (re "\\\\\`${EPREFIX}/usr/share/info\\\\>"))
+ X (re "\\\\\`${EPREFIX}/usr/share\\\\>"))
X (and path
- X ;; move Emacs Info dir before anything else in /usr/share/info
+ X ;; move Emacs Info dir before anything else in /usr/share
X (let* ((p (cons nil (split-string path ":" t))) (q p))
X (while (and (cdr q) (not (string-match re (cadr q))))
X (setq q (cdr q)))
diff --git a/app-editors/emacs/emacs-26.2.ebuild b/app-editors/emacs/emacs-26.2.ebuild
index 457aade942a7..960bddd23123 100644
--- a/app-editors/emacs/emacs-26.2.ebuild
+++ b/app-editors/emacs/emacs-26.2.ebuild
@@ -307,9 +307,9 @@ src_install () {
Y "${EPREFIX}${cdir}")
X (let ((path (getenv "INFOPATH"))
X (dir "${EPREFIX}/usr/share/info/${EMACS_SUFFIX}")
- X (re "\\\\\`${EPREFIX}/usr/share/info\\\\>"))
+ X (re "\\\\\`${EPREFIX}/usr/share\\\\>"))
X (and path
- X ;; move Emacs Info dir before anything else in /usr/share/info
+ X ;; move Emacs Info dir before anything else in /usr/share
X (let* ((p (cons nil (split-string path ":" t))) (q p))
X (while (and (cdr q) (not (string-match re (cadr q))))
X (setq q (cdr q)))
diff --git a/app-editors/emacs/emacs-26.3-r1.ebuild b/app-editors/emacs/emacs-26.3-r1.ebuild
index 3630a7dbf9ad..f591e8b3e316 100644
--- a/app-editors/emacs/emacs-26.3-r1.ebuild
+++ b/app-editors/emacs/emacs-26.3-r1.ebuild
@@ -316,9 +316,9 @@ src_install () {
Y "${EPREFIX}${cdir}")
X (let ((path (getenv "INFOPATH"))
X (dir "${EPREFIX}/usr/share/info/${EMACS_SUFFIX}")
- X (re "\\\\\`${EPREFIX}/usr/share/info\\\\>"))
+ X (re "\\\\\`${EPREFIX}/usr/share\\\\>"))
X (and path
- X ;; move Emacs Info dir before anything else in /usr/share/info
+ X ;; move Emacs Info dir before anything else in /usr/share
X (let* ((p (cons nil (split-string path ":" t))) (q p))
X (while (and (cdr q) (not (string-match re (cadr q))))
X (setq q (cdr q)))