summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSobhan Mohammadpour <sobhan@gentoo.org>2019-04-05 22:10:24 -0400
committerSobhan Mohammadpour <sobhan@gentoo.org>2019-04-05 22:10:49 -0400
commit97578a2fe3d231d1801514aa5f863cfacec0c1ac (patch)
tree1746b507f7e2551087c850363387fcc0439d2008 /app-editors/gedit
parentsys-kernel/gentoo-sources: Linux patch 5.0.7 (diff)
downloadgentoo-97578a2fe3d231d1801514aa5f863cfacec0c1ac.tar.gz
gentoo-97578a2fe3d231d1801514aa5f863cfacec0c1ac.tar.bz2
gentoo-97578a2fe3d231d1801514aa5f863cfacec0c1ac.zip
app-editors/gedit: version bump 3.30 → 3.32
build system changed to meson Package-Manager: Portage-2.3.62, Repoman-2.3.12 RepoMan-Options: --force Signed-off-by: Sobhan Mohammadpour <sobhan@gentoo.org>
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/Manifest1
-rw-r--r--app-editors/gedit/gedit-3.32.0.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/app-editors/gedit/Manifest b/app-editors/gedit/Manifest
index 58efb668cef2..bf07120e7093 100644
--- a/app-editors/gedit/Manifest
+++ b/app-editors/gedit/Manifest
@@ -1,2 +1,3 @@
DIST gedit-3.28.1.tar.xz 3149684 BLAKE2B 6afedcc5de0bd249af3d0fd02339acc2d993aae083dcbfda9212745ab810b81cdb9da655273cb7ccc556644c29d69429d3587fcc9e1faf7aa1c2cee57af09a4b SHA512 f5931ac562cb5005a83eec43048b718ef431e6006b72470fea54ad0e94bd64940ebdec160ee0459ceb5adb235ab111711a2f9fbdc74104d2edd8f287d7474815
DIST gedit-3.30.2.tar.xz 3155628 BLAKE2B 96736adbce987af89b37a712448f42b2a2eeed72d52aa16377d961c9e929fa4e75205eac5987bfc067cc2fecb35aec720d85483c4e2e824a6e8248cc652d2fbe SHA512 58ae7a4c27aeabad670718e39e1860df112d0be00ea622cc8adc185cb5d0e16ac4af65cb3aa45423c7b1b94c88d04d081fe05f3647b054a3e3291abc73c41f6f
+DIST gedit-3.32.0.tar.xz 14793216 BLAKE2B b1d9af7882063a622fe27f8e5aa322e2a1724410c4419d538712fdda2cab10aa59014a82cc1a41b35966dceb1b75ce2613d9c5c98400743b31df76b0114e84e8 SHA512 f25ed05f5d3b7ab7711be32c6516479c8b515d6d5983e3bc3a00407740fb8ec42b1e9a3005473671fc144f4437b9e98355a3669210eefb5bf8288f171188f387
diff --git a/app-editors/gedit/gedit-3.32.0.ebuild b/app-editors/gedit/gedit-3.32.0.ebuild
new file mode 100644
index 000000000000..7e2e758a5964
--- /dev/null
+++ b/app-editors/gedit/gedit-3.32.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+PYTHON_COMPAT=( python3_{4,5,6} )
+VALA_MIN_API_VERSION="0.26"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils gnome.org gnome2-utils meson multilib python-single-r1 vala virtualx xdg
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="+introspection +python gtk-doc vala"
+REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+
+# X libs are not needed for OSX (aqua)
+COMMON_DEPEND="
+ >=dev-libs/libxml2-2.5.0:2
+ >=dev-libs/glib-2.44:2[dbus]
+ >=x11-libs/gtk+-3.22.0:3[introspection?]
+ >=x11-libs/gtksourceview-4.0.2:4[introspection?]
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=net-libs/libsoup-2.60:2.4
+
+ gnome-base/gsettings-desktop-schemas
+ gnome-base/gvfs
+
+ x11-libs/libX11
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_USEDEP}] )
+ >=app-text/gspell-0.2.5:0=
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+DEPEND="${COMMON_DEPEND}
+ ${vala_depend}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ dev-util/itstool
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc documentation)
+ $(meson_use introspection)
+ $(meson_use python plugins)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
+
+src_test() { :; }
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}