summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-03 01:05:57 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-03 01:27:14 +0100
commit62d55ff7fd9acbc540a87cf8decdeb08f0b3cec3 (patch)
tree60130a80f7dfb91cebc54b1b42812d1958f54ca4 /app-editors/kile
parentapp-editors/gvim: remove unused files. (diff)
downloadgentoo-62d55ff7fd9acbc540a87cf8decdeb08f0b3cec3.tar.gz
gentoo-62d55ff7fd9acbc540a87cf8decdeb08f0b3cec3.tar.bz2
gentoo-62d55ff7fd9acbc540a87cf8decdeb08f0b3cec3.zip
app-editors/kile: Add 2.9.91_p20171202 snapshot
beta did not contain translations either, so we may as well get recent fixes while waiting for a release. Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'app-editors/kile')
-rw-r--r--app-editors/kile/Manifest1
-rw-r--r--app-editors/kile/kile-2.9.91_p20171202.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-editors/kile/Manifest b/app-editors/kile/Manifest
index 933176731d4..8ccc1b804f7 100644
--- a/app-editors/kile/Manifest
+++ b/app-editors/kile/Manifest
@@ -1,2 +1,3 @@
DIST kile-2.1.3.tar.bz2 4911212 SHA256 a063ec4fca1ba5a063ffdcdb538967af35ade01d71fa7db6ea691ba2cf88cea2 SHA512 820cb5e2579f243ce87409aa4d483a58b0a2cf1d86bff72dd12264570bfe72e7819c88aa4333080f8281e54e8315e2c11f961b41f13a6215913dfa4f7bd3feda WHIRLPOOL 1bc56ad82c72807fcf93ffeb4dbd4222a7660c00e852378a9007c7aa4a96a5130497ca23815a74c92f631fcb261dbf35f7d5453e849f6fb82c9f3c802058ab31
DIST kile-2.9.91.tar.bz2 3461524 BLAKE2B b8075b97be4570c453ff94769d7d0908006d4cf8d6b2953370e07959660d2af1dc3a0715e1333bd4d61f33ee64d7818b43563827f500b280e51371332b050a89 SHA512 08075adad7d75309148016bbd7f2c4b6f1d5c67808037666deffa49ac26d76cf4329ea39288c23122dabfbb6c83d15bf4f0a2bdaf1479d41064fa63098aba947
+DIST kile-2.9.91_p20171202.tar.gz 3624137 BLAKE2B ee2906a7345826428b7248eb1588a7cbfa43100f537f6ae316d4a425bf11fcfca19df016726934a7fb3c01094a3e824f20f511ee509683b0fc9c84c2d8db75af SHA512 1a08a4c3d71dddf66e1bb68000d3bb9ae458eb985d08d90b89d595993be277c09f37833bd77097716091c4701fcf3750da77f7f720995bcea4bb4bd6c065d691
diff --git a/app-editors/kile/kile-2.9.91_p20171202.ebuild b/app-editors/kile/kile-2.9.91_p20171202.ebuild
new file mode 100644
index 00000000000..1a4c9b0b1a5
--- /dev/null
+++ b/app-editors/kile/kile-2.9.91_p20171202.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=dbaf4c55edd2af4f08571fee364377d48c9a0df5
+KDE_HANDBOOK="forceoptional"
+inherit kde5 vcs-snapshot
+
+DESCRIPTION="Latex Editor and TeX shell based on KDE Frameworks"
+HOMEPAGE="https://kile.sourceforge.io/"
+SRC_URI="https://github.com/KDE/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="FDL-1.2 GPL-2"
+KEYWORDS=""
+IUSE="+pdf +png"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdoctools)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep khtml)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep okular)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtscript)
+ $(add_qt_dep qttest)
+ $(add_qt_dep qtwidgets)
+ pdf? ( app-text/poppler[qt5] )
+"
+RDEPEND="${DEPEND}
+ !app-editors/kile:4
+ $(add_kdeapps_dep konsole)
+ $(add_kdeapps_dep okular 'pdf?')
+ virtual/latex-base
+ virtual/tex-base
+ pdf? (
+ || (
+ app-text/dvipdfmx
+ >=app-text/texlive-core-2014
+ )
+ app-text/ghostscript-gpl
+ )
+ png? (
+ app-text/dvipng
+ virtual/imagemagick-tools[png?]
+ )
+"
+
+DOCS=( kile-remote-control.txt )
+
+src_prepare() {
+ kde5_src_prepare
+
+ # I know upstream wants to help us but it doesn't work..
+ sed -e '/INSTALL( FILES AUTHORS/s/^/#DISABLED /' \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package pdf Poppler)
+ )
+
+ kde5_src_configure
+}