summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-18 23:42:11 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-18 23:42:28 +0200
commit13469be7541ecd62070adbce08811356dc34ede8 (patch)
treeb0c74c7883e4d43580f6abf64d70595ea2fcd212 /app-editors/nano
parentwww-plugins/chrome-binary-plugins: automated update (59.0.3071.61) (diff)
downloadgentoo-13469be7541ecd62070adbce08811356dc34ede8.tar.gz
gentoo-13469be7541ecd62070adbce08811356dc34ede8.tar.bz2
gentoo-13469be7541ecd62070adbce08811356dc34ede8.zip
app-editors/nano: Bump to version 2.8.3
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/Manifest1
-rw-r--r--app-editors/nano/nano-2.8.3.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index 7bc9984ae1c0..f8e4876cd93c 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -1,3 +1,4 @@
DIST nano-2.6.3.tar.gz 2019354 SHA256 4f4054e12f2181c8e436163e931a0a565612242ff9e566c4d1adeda0f91fd503 SHA512 5079c0da976e3cfef9f3980e37c2501837bc66bb98fadd6fe7f02b061b83c99454678833fd43c74e6796cdc4ee9028ccba7a8a05e0f86e7a6517ba4d4c6bc95e WHIRLPOOL 94520ca9c7a11342133adfd3a1e9e9c77a6c07ab18b1b51bf39918b331abc6bd7ebeb937c2ec8ed3e59b8d0468e40f4e5811e66a8aecd469ad42c595c1b61fe4
DIST nano-2.7.5.tar.gz 2031723 SHA256 226be22f46359007aa76499623739f4a7d5fa294a2899c70b21bc09b8d81d907 SHA512 a5332a361c4d0d9d0a77ebb11cdcffa976bee4981d5665b2732a9e6d7a2997566d9345332f2e6e5cb74f0a81be4413f54ca8f719962ab10b32d7ec1c9271973c WHIRLPOOL bd28cde96896ad531bb499504bb1438b358b64e7f6080fa24758bee7c222b4d1df0c395d480d0cef54de8e78a7e457db403a9ef2d6a56033e65299b6d7f95634
DIST nano-2.8.2.tar.gz 2778849 SHA256 0aa9cd6bd5b372ce9a196a9677af58c1826a9235a14daffe604100a9c259854b SHA512 7f4626de4bf8c2250e494c6682743ad599632023a839acff66685ac045a88789061c0a6fc70eba7c3c57f960e633acf425b033d1cc5fbfa644b422515b810f75 WHIRLPOOL a1bfff134cfff6d9f203d252303822d383b206311a738020f771c0222863b58bff33b646336bfe78941112ea01a39a2e013684e660bac0e98f4f3d1a1d65adbb
+DIST nano-2.8.3.tar.gz 2773717 SHA256 2b3b7f383a40899db5367d3c4e663ba0088868c0f9aa4edfd7457c9a0eedbdd1 SHA512 ffedd36252bf13d57c9970840bc05b68c2b9211bf222a47a9aa559c078fdd993929c004d9aae3648e3190cbb32eef7ffb7a57de1c02e6e56b230366b9b55d9a1 WHIRLPOOL 63b4a3a0d93506788ba33553da3a6b7943e3559a2eae37b16700027665711f97313cc7199b189f4668d8a04584907dbf2a4b510f73ade8023729e6569890cd80
diff --git a/app-editors/nano/nano-2.8.3.ebuild b/app-editors/nano/nano-2.8.3.ebuild
new file mode 100644
index 000000000000..ce5e828a27c7
--- /dev/null
+++ b/app-editors/nano/nano-2.8.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
+ inherit git-r3 autotools
+else
+ MY_P=${PN}-${PV/_}
+ SRC_URI="https://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
+
+LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
+ sys-libs/ncurses:0=[static-libs(+)]
+ magic? ( sys-apps/file[static-libs(+)] )
+ nls? ( virtual/libintl )
+ !ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+ static? ( ${LIB_DEPEND} )"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+ default
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ local myconf=()
+ case ${CHOST} in
+ *-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
+ esac
+ econf \
+ --bindir="${EPREFIX}"/bin \
+ --htmldir=/trash \
+ $(use_enable !minimal color) \
+ $(use_enable !minimal multibuffer) \
+ $(use_enable !minimal nanorc) \
+ --disable-wrapping-as-root \
+ $(use_enable magic libmagic) \
+ $(use_enable spell speller) \
+ $(use_enable justify) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable unicode utf8) \
+ $(use_enable minimal tiny) \
+ $(usex ncurses --without-slang $(use_with slang)) \
+ "${myconf[@]}"
+}
+
+src_install() {
+ default
+ rm -rf "${D}"/trash
+
+ dodoc doc/sample.nanorc
+ docinto html
+ dodoc doc/faq.html
+ insinto /etc
+ newins doc/sample.nanorc nanorc
+ if ! use minimal ; then
+ # Enable colorization by default.
+ sed -i \
+ -e '/^# include /s:# *::' \
+ "${ED}"/etc/nanorc || die
+ fi
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+}