summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2017-10-31 12:36:22 -0700
committerPatrice Clement <monsieurp@gentoo.org>2018-01-05 18:43:40 +0100
commit7ec4b117cc739c03067cfab7607c73af2c52feca (patch)
tree2dc60c1b83c593bffb800058df1782965c6fe027 /app-editors/neovim
parentdev-python/neovim-remote: new package. (diff)
downloadgentoo-7ec4b117cc739c03067cfab7607c73af2c52feca.tar.gz
gentoo-7ec4b117cc739c03067cfab7607c73af2c52feca.tar.bz2
gentoo-7ec4b117cc739c03067cfab7607c73af2c52feca.zip
app-editors/neovim: add remote USE flag.
Diffstat (limited to 'app-editors/neovim')
-rw-r--r--app-editors/neovim/metadata.xml1
-rw-r--r--app-editors/neovim/neovim-0.2.0-r1.ebuild82
-rw-r--r--app-editors/neovim/neovim-0.2.2-r1.ebuild82
-rw-r--r--app-editors/neovim/neovim-9999.ebuild5
4 files changed, 168 insertions, 2 deletions
diff --git a/app-editors/neovim/metadata.xml b/app-editors/neovim/metadata.xml
index 0671c79ddf39..158212f33e00 100644
--- a/app-editors/neovim/metadata.xml
+++ b/app-editors/neovim/metadata.xml
@@ -9,6 +9,7 @@
<flag name="clipboard">Enable clipboard support through a provider</flag>
<flag name="nvimpager">Install nvimpager symlink to less.sh macro</flag>
<flag name="jemalloc">Use <pkg>dev-libs/jemalloc</pkg> for allocations</flag>
+ <flag name="remote">Enable support for remote options using nvr</flag>
<flag name="tui">Build the neovim unix tui</flag>
<flag name="luajit">Use <pkg>dev-lang/luajit</pkg> instead of
<pkg>dev-lang/lua</pkg></flag>
diff --git a/app-editors/neovim/neovim-0.2.0-r1.ebuild b/app-editors/neovim/neovim-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..9694b6c32c21
--- /dev/null
+++ b/app-editors/neovim/neovim-0.2.0-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="Vim-fork focused on extensibility and agility."
+HOMEPAGE="https://neovim.io"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/neovim/neovim.git"
+else
+ SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0 vim"
+SLOT="0"
+IUSE="+clipboard +luajit +nvimpager python remote ruby +tui +jemalloc"
+
+CDEPEND=">=dev-libs/libuv-1.2.0
+ >=dev-libs/msgpack-1.0.0
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? (
+ dev-lang/lua:=
+ dev-lua/LuaBitOp
+ )
+ tui? (
+ >=dev-libs/libtermkey-0.19
+ >=dev-libs/unibilium-1.1.1
+ )
+ dev-libs/libvterm
+ dev-lua/lpeg[luajit=]
+ dev-lua/mpack[luajit=]
+ jemalloc? ( dev-libs/jemalloc )"
+
+DEPEND="
+ ${CDEPEND}
+ dev-util/gperf
+ virtual/libiconv
+ virtual/libintl"
+
+RDEPEND="
+ ${CDEPEND}
+ python? ( dev-python/neovim-python-client )
+ ruby? ( dev-ruby/neovim-ruby-client )
+ remote? ( dev-python/neovim-remote )
+ clipboard? ( || ( x11-misc/xsel x11-misc/xclip ) )"
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+src_prepare() {
+ # use our system vim dir
+ sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \
+ -i src/nvim/globals.h || die
+
+ # add eclass to bash filetypes
+ sed -e 's|*.ebuild|*.ebuild,*.eclass|' -i runtime/filetype.vim || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DFEAT_TUI=$(usex tui)
+ -DENABLE_JEMALLOC=$(usex jemalloc)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # install a default configuration file
+ insinto /etc/vim
+ doins "${FILESDIR}"/sysinit.vim
+
+ # conditionally install a symlink for nvimpager
+ if use nvimpager; then
+ dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
+ fi
+}
diff --git a/app-editors/neovim/neovim-0.2.2-r1.ebuild b/app-editors/neovim/neovim-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..9694b6c32c21
--- /dev/null
+++ b/app-editors/neovim/neovim-0.2.2-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="Vim-fork focused on extensibility and agility."
+HOMEPAGE="https://neovim.io"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/neovim/neovim.git"
+else
+ SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0 vim"
+SLOT="0"
+IUSE="+clipboard +luajit +nvimpager python remote ruby +tui +jemalloc"
+
+CDEPEND=">=dev-libs/libuv-1.2.0
+ >=dev-libs/msgpack-1.0.0
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? (
+ dev-lang/lua:=
+ dev-lua/LuaBitOp
+ )
+ tui? (
+ >=dev-libs/libtermkey-0.19
+ >=dev-libs/unibilium-1.1.1
+ )
+ dev-libs/libvterm
+ dev-lua/lpeg[luajit=]
+ dev-lua/mpack[luajit=]
+ jemalloc? ( dev-libs/jemalloc )"
+
+DEPEND="
+ ${CDEPEND}
+ dev-util/gperf
+ virtual/libiconv
+ virtual/libintl"
+
+RDEPEND="
+ ${CDEPEND}
+ python? ( dev-python/neovim-python-client )
+ ruby? ( dev-ruby/neovim-ruby-client )
+ remote? ( dev-python/neovim-remote )
+ clipboard? ( || ( x11-misc/xsel x11-misc/xclip ) )"
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+src_prepare() {
+ # use our system vim dir
+ sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \
+ -i src/nvim/globals.h || die
+
+ # add eclass to bash filetypes
+ sed -e 's|*.ebuild|*.ebuild,*.eclass|' -i runtime/filetype.vim || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DFEAT_TUI=$(usex tui)
+ -DENABLE_JEMALLOC=$(usex jemalloc)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # install a default configuration file
+ insinto /etc/vim
+ doins "${FILESDIR}"/sysinit.vim
+
+ # conditionally install a symlink for nvimpager
+ if use nvimpager; then
+ dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
+ fi
+}
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index a37942870e06..9694b6c32c21 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -11,12 +11,12 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/neovim/neovim.git"
else
SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~x86"
fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="+clipboard +luajit +nvimpager python ruby +tui +jemalloc"
+IUSE="+clipboard +luajit +nvimpager python remote ruby +tui +jemalloc"
CDEPEND=">=dev-libs/libuv-1.2.0
>=dev-libs/msgpack-1.0.0
@@ -44,6 +44,7 @@ RDEPEND="
${CDEPEND}
python? ( dev-python/neovim-python-client )
ruby? ( dev-ruby/neovim-ruby-client )
+ remote? ( dev-python/neovim-remote )
clipboard? ( || ( x11-misc/xsel x11-misc/xclip ) )"
CMAKE_BUILD_TYPE=RelWithDebInfo