summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-07-19 16:15:15 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-07-19 16:15:26 +0200
commit1d39f31bc45d3e0627ed1a58e17236024f18d78e (patch)
tree4d7c99c47f598c1ccb09f6a87afcb1d2292c3121 /app-editors/pyvim/pyvim-3.0.2.ebuild
parentnet-analyzer/scapy: Update live ebuild (diff)
downloadgentoo-1d39f31bc45d3e0627ed1a58e17236024f18d78e.tar.gz
gentoo-1d39f31bc45d3e0627ed1a58e17236024f18d78e.tar.bz2
gentoo-1d39f31bc45d3e0627ed1a58e17236024f18d78e.zip
app-editors/pyvim: new ebuild.
pyvim is an implementation of Vim in Python. Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-editors/pyvim/pyvim-3.0.2.ebuild')
-rw-r--r--app-editors/pyvim/pyvim-3.0.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-editors/pyvim/pyvim-3.0.2.ebuild b/app-editors/pyvim/pyvim-3.0.2.ebuild
new file mode 100644
index 000000000000..f0ba40a9fbc0
--- /dev/null
+++ b/app-editors/pyvim/pyvim-3.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of Vim in Python"
+HOMEPAGE="https://pypi.org/project/pyvim https://github.com/prompt-toolkit/pyvim"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-eselect/eselect-vi
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/prompt_toolkit[${PYTHON_USEDEP}]"
+
+eselect_vi_update() {
+ einfo "Calling eselect vi update..."
+ eselect vi update --if-unset
+ eend $?
+}
+
+pkg_postinst() {
+ eselect_vi_update
+}
+
+pkg_postrm() {
+ eselect_vi_update
+}