summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna Vyalkova <cyber+gentoo@sysrq.in>2022-06-22 19:21:52 +0500
committerSam James <sam@gentoo.org>2022-07-15 02:49:47 +0100
commit06df30813f1c4597e25b18061ce81f696c6c1134 (patch)
tree4e2c22f8577fc9dbe676ab0c3395381e10cbfa68 /app-editors/pyvim/pyvim-3.0.3.ebuild
parentsci-geosciences/grass: add support for sci-libs/pdal (diff)
downloadgentoo-06df30813f1c4597e25b18061ce81f696c6c1134.tar.gz
gentoo-06df30813f1c4597e25b18061ce81f696c6c1134.tar.bz2
gentoo-06df30813f1c4597e25b18061ce81f696c6c1134.zip
app-editors/pyvim: add 3.0.3
* EAPI 7 -> 8 * bump PYTHON_COMPAT * enable PEP517 * fix QA issues * enable tests Signed-off-by: Anna Vyalkova <cyber+gentoo@sysrq.in> Closes: https://github.com/gentoo/gentoo/pull/26042 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/pyvim/pyvim-3.0.3.ebuild')
-rw-r--r--app-editors/pyvim/pyvim-3.0.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-editors/pyvim/pyvim-3.0.3.ebuild b/app-editors/pyvim/pyvim-3.0.3.ebuild
new file mode 100644
index 000000000000..a82ef87a6274
--- /dev/null
+++ b/app-editors/pyvim/pyvim-3.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 edo
+
+COMMIT="14118ad2e4d0da2e955fd9069b8772408307618b"
+DESCRIPTION="An implementation of Vim in Python"
+HOMEPAGE="https://pypi.org/project/pyvim/ https://github.com/prompt-toolkit/pyvim"
+SRC_URI="https://github.com/prompt-toolkit/${PN}/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/prompt_toolkit[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+IDEPEND="
+ app-eselect/eselect-vi
+"
+
+distutils_enable_tests pytest
+
+eselect_vi_update() {
+ edob eselect vi update --if-unset
+}
+
+pkg_postinst() {
+ eselect_vi_update
+}
+
+pkg_postrm() {
+ eselect_vi_update
+}