summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-02 03:22:24 +0000
committerSam James <sam@gentoo.org>2022-01-02 03:22:24 +0000
commita9eb43584ad736962521c475d4e73fdb369103cf (patch)
tree62c55c770cd94b7b54c3503bce2d4231a13b963f /app-editors/retext
parentdev-util/cppcheck: add 2.6.3 (diff)
downloadgentoo-a9eb43584ad736962521c475d4e73fdb369103cf.tar.gz
gentoo-a9eb43584ad736962521c475d4e73fdb369103cf.tar.bz2
gentoo-a9eb43584ad736962521c475d4e73fdb369103cf.zip
app-editors/retext: add 7.2.2
Closes: https://bugs.gentoo.org/830419 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/retext')
-rw-r--r--app-editors/retext/Manifest1
-rw-r--r--app-editors/retext/retext-7.2.2.ebuild70
-rw-r--r--app-editors/retext/retext-9999.ebuild20
3 files changed, 81 insertions, 10 deletions
diff --git a/app-editors/retext/Manifest b/app-editors/retext/Manifest
index b431069e1862..f36087851d43 100644
--- a/app-editors/retext/Manifest
+++ b/app-editors/retext/Manifest
@@ -1,2 +1,3 @@
DIST ReText-7.1.0.tar.gz 484989 BLAKE2B 74f07218cba1d76d011e5347c65ec03ef84da29119c177f35cca206cb269ae4755fdb85448562a378d2ab610930d23b4eccb62a39807409c6e80a68102be2034 SHA512 92333f31f7a57440d642246ed30156384285bb44640a0d6e7654e82749681893eaef3cb16e41fa2d7b618aa59f1ea8cb07d431736b00f35cb9130d7294e3d105
DIST ReText-7.2.1.tar.gz 522364 BLAKE2B 6334fd6dc1c625378426e408a0d4ad6bb9c02dcba18fcfa566d61ce006a44c34327686a8eb756f2195620e644e096b9393a7cfa73229aa0dab7d29ddf715edaa SHA512 1a375acb40792e3cae9f955a75ebac7c30c9e5cc719477989b28d8d7f06e18ad14d98f1a600a5b6d050b3276ef22bd46b5f1f07af90d561cca500674ff461604
+DIST ReText-7.2.2.tar.gz 522652 BLAKE2B f9b19f985c1381eade324758c4dc6bf2e5f74bc3f5bfc27afa10462b7387f64a3e72edd5875aabf1831f1f0a942f395e43b124c172cac8cec4b9f19334661484 SHA512 68345b57b2c5446158ed3a6f97b5ead103ef1c99a3aea9cbc69ef7d0807fb64546f38ebde2969b94429eeed6450abb345fecc566dcf6e0767fe84c4e27348e53
diff --git a/app-editors/retext/retext-7.2.2.ebuild b/app-editors/retext/retext-7.2.2.ebuild
new file mode 100644
index 000000000000..ac4f08fb2467
--- /dev/null
+++ b/app-editors/retext/retext-7.2.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Please don't add pypy support before testing if it's actually supported. The
+# old compat matrix is no longer accessible as of 2021-02-13 but stated back
+# in 2020-07-05 that PyQt5 was explicitly not supported.
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit distutils-r1 optfeature virtualx xdg-utils
+
+MY_PN="ReText"
+MY_P="${MY_PN}-${PV/_/~}"
+
+DESCRIPTION="Simple editor for Markdown and reStructuredText"
+HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/retext-project/retext.git"
+else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ >=dev-python/markups-3.1.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/python-markdown-math[${PYTHON_USEDEP}]
+ dev-python/PyQt5[dbus,gui,printsupport,widgets,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-python/PyQt5[testlib,${PYTHON_USEDEP}] )"
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ optfeature "dictionary support" dev-python/pyenchant
+ # See https://bugs.gentoo.org/772197.
+ optfeature "rendering with webengine" dev-python/PyQtWebEngine
+
+ einfo "Starting with retext-7.0.4 the markdown-math plugin is installed."
+ einfo "Note that you can use different math delimiters, e.g. \(...\) for inline math."
+ einfo "For more details take a look at:"
+ einfo "https://github.com/mitya57/python-markdown-math#math-delimiters"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
diff --git a/app-editors/retext/retext-9999.ebuild b/app-editors/retext/retext-9999.ebuild
index 13399224b736..ac4f08fb2467 100644
--- a/app-editors/retext/retext-9999.ebuild
+++ b/app-editors/retext/retext-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
# Please don't add pypy support before testing if it's actually supported. The
# old compat matrix is no longer accessible as of 2021-02-13 but stated back
# in 2020-07-05 that PyQt5 was explicitly not supported.
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8,9,10} )
inherit distutils-r1 optfeature virtualx xdg-utils
@@ -16,14 +16,14 @@ MY_P="${MY_PN}-${PV/_/~}"
DESCRIPTION="Simple editor for Markdown and reStructuredText"
HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
-if [[ ${PV} == *9999 ]]
- then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/retext-project/retext.git"
- else
- SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${MY_P}"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/retext-project/retext.git"
+else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+
+ KEYWORDS="~amd64 ~riscv ~x86"
fi
LICENSE="GPL-2+"