summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDongsu Park <dongsu@kinvolk.io>2020-12-04 10:30:37 +0100
committerPatrice Clement <monsieurp@gentoo.org>2020-12-06 23:45:57 +0100
commit3f89cb507efa8acfcfdec5b90ba17aca85bbdd44 (patch)
tree815943b453ffa3994d2762e42f8fcee27b60cdcf /app-editors/vim
parentapp-editors/neovim: add dev-libs/treesitter as dep. (diff)
downloadgentoo-3f89cb507efa8acfcfdec5b90ba17aca85bbdd44.tar.gz
gentoo-3f89cb507efa8acfcfdec5b90ba17aca85bbdd44.tar.bz2
gentoo-3f89cb507efa8acfcfdec5b90ba17aca85bbdd44.zip
app-editors/vim: do not create symlink vimdiff for minimal.
A symlink `vimdiff` should not be created, if the USE flag `minimal` is enabled. Otherwise running `vimdiff` results in failure like that: $ vimdiff aaa bbb This Vim was not compiled with the diff feature. Signed-off-by: Dongsu Park <dongsu@kinvolk.io> Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/18496
Diffstat (limited to 'app-editors/vim')
-rw-r--r--app-editors/vim/vim-8.2.0360.ebuild4
-rw-r--r--app-editors/vim/vim-8.2.0508.ebuild4
-rw-r--r--app-editors/vim/vim-8.2.0638.ebuild4
-rw-r--r--app-editors/vim/vim-8.2.0814.ebuild4
-rw-r--r--app-editors/vim/vim-9999.ebuild4
5 files changed, 15 insertions, 5 deletions
diff --git a/app-editors/vim/vim-8.2.0360.ebuild b/app-editors/vim/vim-8.2.0360.ebuild
index d80d7777de3f..8a757434c46f 100644
--- a/app-editors/vim/vim-8.2.0360.ebuild
+++ b/app-editors/vim/vim-8.2.0360.ebuild
@@ -276,7 +276,9 @@ src_install() {
# Note: Do not install symlinks for 'vi', 'ex', or 'view', as these are
# managed by eselect-vi
dobin src/vim
- dosym vim /usr/bin/vimdiff
+ if ! use minimal ; then
+ dosym vim /usr/bin/vimdiff
+ fi
dosym vim /usr/bin/rvim
dosym vim /usr/bin/rview
if use vim-pager ; then
diff --git a/app-editors/vim/vim-8.2.0508.ebuild b/app-editors/vim/vim-8.2.0508.ebuild
index 5bc04c0d2b05..372853638330 100644
--- a/app-editors/vim/vim-8.2.0508.ebuild
+++ b/app-editors/vim/vim-8.2.0508.ebuild
@@ -276,7 +276,9 @@ src_install() {
# Note: Do not install symlinks for 'vi', 'ex', or 'view', as these are
# managed by eselect-vi
dobin src/vim
- dosym vim /usr/bin/vimdiff
+ if ! use minimal ; then
+ dosym vim /usr/bin/vimdiff
+ fi
dosym vim /usr/bin/rvim
dosym vim /usr/bin/rview
if use vim-pager ; then
diff --git a/app-editors/vim/vim-8.2.0638.ebuild b/app-editors/vim/vim-8.2.0638.ebuild
index 5bc04c0d2b05..372853638330 100644
--- a/app-editors/vim/vim-8.2.0638.ebuild
+++ b/app-editors/vim/vim-8.2.0638.ebuild
@@ -276,7 +276,9 @@ src_install() {
# Note: Do not install symlinks for 'vi', 'ex', or 'view', as these are
# managed by eselect-vi
dobin src/vim
- dosym vim /usr/bin/vimdiff
+ if ! use minimal ; then
+ dosym vim /usr/bin/vimdiff
+ fi
dosym vim /usr/bin/rvim
dosym vim /usr/bin/rview
if use vim-pager ; then
diff --git a/app-editors/vim/vim-8.2.0814.ebuild b/app-editors/vim/vim-8.2.0814.ebuild
index 7becfb7071c6..946d309a7f6f 100644
--- a/app-editors/vim/vim-8.2.0814.ebuild
+++ b/app-editors/vim/vim-8.2.0814.ebuild
@@ -276,7 +276,9 @@ src_install() {
# Note: Do not install symlinks for 'vi', 'ex', or 'view', as these are
# managed by eselect-vi
dobin src/vim
- dosym vim /usr/bin/vimdiff
+ if ! use minimal ; then
+ dosym vim /usr/bin/vimdiff
+ fi
dosym vim /usr/bin/rvim
dosym vim /usr/bin/rview
if use vim-pager ; then
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index 5bc04c0d2b05..372853638330 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -276,7 +276,9 @@ src_install() {
# Note: Do not install symlinks for 'vi', 'ex', or 'view', as these are
# managed by eselect-vi
dobin src/vim
- dosym vim /usr/bin/vimdiff
+ if ! use minimal ; then
+ dosym vim /usr/bin/vimdiff
+ fi
dosym vim /usr/bin/rvim
dosym vim /usr/bin/rview
if use vim-pager ; then