summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2016-02-28 02:16:48 -0600
committerRyan Hill <rhill@gentoo.org>2016-02-28 02:16:48 -0600
commit255694be1a6a6e71292b75d66b97b1662b1994a1 (patch)
treeadc41e5245e6333b900e95f016e7e27cb9b50188 /app-editors/xmlcopyeditor
parentnet-analyzer/netcat6: keywording arm64 (diff)
downloadgentoo-255694be1a6a6e71292b75d66b97b1662b1994a1.tar.gz
gentoo-255694be1a6a6e71292b75d66b97b1662b1994a1.tar.bz2
gentoo-255694be1a6a6e71292b75d66b97b1662b1994a1.zip
app-editors/xmlcopyeditor: Version bump. (bug #562998)
Bumped to a version supporting wxGTK 3.0. Removed GuideXML support. Package-Manager: portage-2.2.27 Signed-off-by: Ryan Hill <rhill@gentoo.org>
Diffstat (limited to 'app-editors/xmlcopyeditor')
-rw-r--r--app-editors/xmlcopyeditor/Manifest1
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-editors/xmlcopyeditor/Manifest b/app-editors/xmlcopyeditor/Manifest
index 529450773bb8..d836b171bfea 100644
--- a/app-editors/xmlcopyeditor/Manifest
+++ b/app-editors/xmlcopyeditor/Manifest
@@ -2,3 +2,4 @@ DIST GuideXML-templates.tar.gz 884 SHA256 3ede041b74a64a3f262455728486a616ffb496
DIST xmlcopyeditor-1.2.0.12.tar.gz 4052354 SHA256 7f33795ca8c6c25207970a4933ff41651314dbd9fd73e94ae68dfde100baa415 SHA512 501ad0302d0dfd3a695adc430ca4b2a720092c04797ee9d2da597971be3c10a51984ab3d444b044f058ba6b1b7a384f71c16aac9fa30e7eb32d509d56972e349 WHIRLPOOL 7b731890a61a2c6742c3c97de9e661fe625a72d289711f9d04cd376e16b3f37dfde8b2d595fdd7ab35d1de8b2e992fdd0e2c824f9b915744f2e52fd2830a9f86
DIST xmlcopyeditor-1.2.0.6-2.tar.gz 1526457 SHA256 9a4ba41d67604d303b1728877768f9e3ef85d56e6f580b0eeef840e12b84f02c SHA512 9833a520ed835ea1bb285ace9deca3e309a5b31fd923582f79302cd1b81e5caf1de39296efe6eda33d329b2c40aabb10bcd7b476e61d8b3ea6e5aac43b361b72 WHIRLPOOL 9e79075e4a0b325a08b9784a5bcdfdd414390d161440a47394bf63ed5944e700fef4c61e6e29c508ec7bfee802f527a5b393824d48ac82bd55527231ba341916
DIST xmlcopyeditor-1.2.0.9.tar.gz 1815995 SHA256 850df750f3561320f6ab1b612e00cd2b9ecc2bed49ab1dcc261af78d0a28b7f7 SHA512 a375476fe1140a2089e7322c9d219ae3440a3b971947ced440f71c72e99b3b3998419bf34303df3e6093378336b2d69652c4e7dc93880ff40d8c3fac48103eaa WHIRLPOOL 75bbd422c7618650d183eac45f24871a80bf8cffcaa9f3d320d7fcb0a282cabf1f14b9f825e893373b85d99bd6c5f58db882a91eb427c9775822ce417f5d5278
+DIST xmlcopyeditor-1.2.1.3.tar.gz 4266907 SHA256 9b684b5042b4af85d3626fd55108bd1d63c0007b5c794ef7cc4b026012b29d2f SHA512 1adda58bc262cd22898ba22eed3cad9f4a51f199e779172af2d51c5d7bf6dac072b9015b90906236de83d7acebe29d0aae6ae73998ec9d9b3c58b02f081e0b4d WHIRLPOOL c536382a6669f54f7abb84f31de57fc1cc11c85ddc20a90828c39e5edb2d112a741b9d1d7e5a0011b4c4ae337bf12f31ec556b9fd4a54da2219b754e48434df5
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3.ebuild
new file mode 100644
index 000000000000..c28d341dc274
--- /dev/null
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+WX_GTK_VER="3.0"
+
+inherit autotools wxwidgets
+
+DESCRIPTION="XML Copy Editor is a fast, free, validating XML editor"
+HOMEPAGE="http://xml-copy-editor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xml-copy-editor/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="aqua nls"
+
+RDEPEND="
+ app-text/aspell
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/xerces-c[icu]
+ dev-libs/libpcre
+ !aqua? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
+ aqua? ( x11-libs/wxGTK:${WX_GTK_VER}[aqua] )"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-util/intltool"
+
+DOCS=( AUTHORS ChangeLog README NEWS )
+
+src_prepare() {
+ # bug #440744
+ sed -i -e 's/ -Wall -g -fexceptions//g' configure.ac || die
+ eautoreconf
+
+ need-wxwidgets unicode
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}