summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-02-08 22:13:04 +0100
committerUlrich Müller <ulm@gentoo.org>2018-02-08 22:13:37 +0100
commitbb5c2d4765d595b56004ddd06acd8b671d049aec (patch)
tree25b02553188b3817a4229b8491949a94c57bdc26 /app-editors/zile/zile-2.4.13.ebuild
parentapp-admin/calamares: Remove 3.1.11 (diff)
downloadgentoo-bb5c2d4765d595b56004ddd06acd8b671d049aec.tar.gz
gentoo-bb5c2d4765d595b56004ddd06acd8b671d049aec.tar.bz2
gentoo-bb5c2d4765d595b56004ddd06acd8b671d049aec.zip
app-editors/zile: Run tests with a sane terminal type.
Closes: https://bugs.gentoo.org/646912 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-editors/zile/zile-2.4.13.ebuild')
-rw-r--r--app-editors/zile/zile-2.4.13.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/app-editors/zile/zile-2.4.13.ebuild b/app-editors/zile/zile-2.4.13.ebuild
index d6136b4f5a1e..52a77f4ede36 100644
--- a/app-editors/zile/zile-2.4.13.ebuild
+++ b/app-editors/zile/zile-2.4.13.ebuild
@@ -33,6 +33,17 @@ src_configure() {
CURSES_LIB="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
}
+src_test() {
+ if tput cup 0 0 >/dev/null || tput cuu1 >/dev/null; then
+ # We have a sane terminal that can move the cursor
+ emake check
+ else
+ ewarn "Terminal type \"${TERM}\" is too stupid to run zile"
+ ewarn "Running the tests with unset TERM instead"
+ ( unset TERM; emake check )
+ fi
+}
+
src_install() {
emake DESTDIR="${D}" install