summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Reifschneider <tranquility@gentoo.org>2019-01-09 22:28:20 +0100
committerOle Reifschneider <tranquility@gentoo.org>2019-01-09 22:29:47 +0100
commit5c6d47d7a0a41522a998578f490d256d4b3bd34b (patch)
treee32454492c2822a36e4f4c6d9c450096568d9d92 /app-editors
parentdev-qt/qtcore: remove 5.11.3-r1 (diff)
downloadgentoo-5c6d47d7a0a41522a998578f490d256d4b3bd34b.tar.gz
gentoo-5c6d47d7a0a41522a998578f490d256d4b3bd34b.tar.bz2
gentoo-5c6d47d7a0a41522a998578f490d256d4b3bd34b.zip
app-editors/neovim: Bump version to 0.3.2
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Ole Reifschneider <tranquility@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim/Manifest1
-rw-r--r--app-editors/neovim/neovim-0.3.2.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/app-editors/neovim/Manifest b/app-editors/neovim/Manifest
index 735553ccd998..31f78c939b2f 100644
--- a/app-editors/neovim/Manifest
+++ b/app-editors/neovim/Manifest
@@ -2,3 +2,4 @@ DIST neovim-0.2.0.tar.gz 7846467 BLAKE2B ee929122b3855ccab6247a0e8ab975b09d77e10
DIST neovim-0.2.2.tar.gz 8325879 BLAKE2B dbf43c5927b8c8719adae9a3f73c57429de47f1b7c7489a118b7467df2f0d32cd02df8e10889727b4dd77fe8b4fb4f95520c678d6775d5d908705770a47cec0c SHA512 5609defe86ac98356f1b9ae9adc6049bb4df920a9a2ae3104f761d52d4dd54cbc84d2596231595dd9b0aa97201fef2121e6c5c86a19267ab6b871dbf4b568209
DIST neovim-0.3.0.tar.gz 8903630 BLAKE2B 44936f0042be1771725a42168865d65f9afe048c116ed0d5f1542dffd8206a21dc4cbab1e08e97fdc27083251655c43df0451c5808ed6c6ad99eb2d582c55b9b SHA512 8944be5562a69d5da5bce3a6673cc0b1930eb5592eb15c40139a1991f89f63435141449e7b4371ee28ff426575fcad475396e3d982004e17a902bda1d8ae6a95
DIST neovim-0.3.1.tar.gz 8937900 BLAKE2B 05de31d194a69b9cecd34210ecfe7460968f4255c850b9bb93b8ab8f5721463c434dd9249a43153c6e65584192bbe0a2720a474c5d8b3b73776148179d18943b SHA512 42c541608509dc0335203ee1c008045f0eaeebce8e18dffc554ab22a029da700bba9b8c721bd9d68337ddb4a56f8cf034fad2a3eb88d36baf8295e6648fce506
+DIST neovim-0.3.2.tar.gz 9230960 BLAKE2B c9d0ee2f679f411c3ece2aa186e31d0143479f6ec19d4d54c34cd4be519a92e9f213fc821b347a0e3af6817b6ce745cdff523af41d5b558940b76d9df726253b SHA512 1192d9330da3ab543dcb39bdff517637c7a52be558ad07a60de27bbf051432064edc230b46ddd9cdcae006ba1340550128e4d4ced7105f1aab57b13c2c4479ae
diff --git a/app-editors/neovim/neovim-0.3.2.ebuild b/app-editors/neovim/neovim-0.3.2.ebuild
new file mode 100644
index 000000000000..f2102ef474a1
--- /dev/null
+++ b/app-editors/neovim/neovim-0.3.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg-utils
+
+DESCRIPTION="Vim-fork focused on extensibility and agility."
+HOMEPAGE="https://neovim.io"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/neovim/neovim.git"
+else
+ SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0 vim"
+SLOT="0"
+IUSE="+clipboard +luajit +nvimpager python remote ruby +tui +jemalloc"
+
+CDEPEND=">=dev-libs/libuv-1.2.0:0=
+ >=dev-libs/msgpack-1.0.0:0=
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? (
+ dev-lang/lua:=
+ dev-lua/LuaBitOp
+ )
+ tui? (
+ >=dev-libs/libtermkey-0.19
+ >=dev-libs/unibilium-2.0.0:0=
+ )
+ dev-libs/libvterm
+ dev-lua/lpeg[luajit=]
+ dev-lua/mpack[luajit=]
+ jemalloc? ( dev-libs/jemalloc )
+ net-libs/libnsl"
+
+DEPEND="
+ ${CDEPEND}
+ dev-util/gperf
+ virtual/libiconv
+ virtual/libintl"
+
+RDEPEND="
+ ${CDEPEND}
+ python? ( dev-python/neovim-python-client )
+ ruby? ( dev-ruby/neovim-ruby-client )
+ remote? ( dev-python/neovim-remote )
+ clipboard? ( || ( x11-misc/xsel x11-misc/xclip ) )"
+
+CMAKE_BUILD_TYPE=Release
+
+src_prepare() {
+ # use our system vim dir
+ sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \
+ -i src/nvim/globals.h || die
+
+ # add eclass to bash filetypes
+ sed -e 's|*.ebuild|*.ebuild,*.eclass|' -i runtime/filetype.vim || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DFEAT_TUI=$(usex tui)
+ -DENABLE_JEMALLOC=$(usex jemalloc)
+ -DPREFER_LUA=$(usex luajit no yes)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # install a default configuration file
+ insinto /etc/vim
+ doins "${FILESDIR}"/sysinit.vim
+
+ # conditionally install a symlink for nvimpager
+ if use nvimpager; then
+ dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
+ fi
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}