summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-10-11 23:28:09 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-10-11 23:28:30 +1100
commit7a6bb58976a8f5a656b708a24397feac7927dae8 (patch)
tree18459d7b652e19622a28217e7628ddd316d8f55b /app-editors
parentnet-libs/nodejs: Version 10.12.0 (diff)
downloadgentoo-7a6bb58976a8f5a656b708a24397feac7927dae8.tar.gz
gentoo-7a6bb58976a8f5a656b708a24397feac7927dae8.tar.bz2
gentoo-7a6bb58976a8f5a656b708a24397feac7927dae8.zip
app-editors/notepadqq: fix build with Qt 5.11
Close: https://bugs.gentoo.org/665286 Signed-off-by: Michael Palimaka <kensington@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/notepadqq/files/notepadqq-1.4.8-qt-5.11.patch26
-rw-r--r--app-editors/notepadqq/notepadqq-1.4.8.ebuild4
-rw-r--r--app-editors/notepadqq/notepadqq-9999.ebuild4
3 files changed, 32 insertions, 2 deletions
diff --git a/app-editors/notepadqq/files/notepadqq-1.4.8-qt-5.11.patch b/app-editors/notepadqq/files/notepadqq-1.4.8-qt-5.11.patch
new file mode 100644
index 000000000000..d656bd920940
--- /dev/null
+++ b/app-editors/notepadqq/files/notepadqq-1.4.8-qt-5.11.patch
@@ -0,0 +1,26 @@
+Bug: https://bugs.gentoo.org/665286
+
+From 8fabccfe2682583f5190b84dbc1922cce9c8d82b Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Thu, 11 Oct 2018 23:23:08 +1100
+Subject: [PATCH] Add missing include.
+
+---
+ src/ui/EditorNS/languageservice.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/ui/EditorNS/languageservice.cpp b/src/ui/EditorNS/languageservice.cpp
+index bbe03dc..9a0f212 100644
+--- a/src/ui/EditorNS/languageservice.cpp
++++ b/src/ui/EditorNS/languageservice.cpp
+@@ -6,6 +6,7 @@
+ #include <QJsonDocument>
+ #include <QJsonObject>
+ #include <QJsonValue>
++#include <QTextStream>
+
+ namespace EditorNS {
+
+--
+2.18.1
+
diff --git a/app-editors/notepadqq/notepadqq-1.4.8.ebuild b/app-editors/notepadqq/notepadqq-1.4.8.ebuild
index d85db1653d71..0ce0b7273f52 100644
--- a/app-editors/notepadqq/notepadqq-1.4.8.ebuild
+++ b/app-editors/notepadqq/notepadqq-1.4.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,6 +32,8 @@ DEPEND="
dev-qt/qtsvg:5
"
+PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )
+
src_prepare() {
default
diff --git a/app-editors/notepadqq/notepadqq-9999.ebuild b/app-editors/notepadqq/notepadqq-9999.ebuild
index 9db258a39568..18d0df4c8035 100644
--- a/app-editors/notepadqq/notepadqq-9999.ebuild
+++ b/app-editors/notepadqq/notepadqq-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -33,6 +33,8 @@ DEPEND="
dev-qt/qtsvg:5
"
+PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )
+
src_prepare() {
default