summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-31 18:40:49 +0000
committerSam James <sam@gentoo.org>2023-01-31 18:42:21 +0000
commit7d6862b0cd7c79d091a057f2d51ad091d34a8cf4 (patch)
tree2ca9b2476a3606433a204291a984f0b09f19b3b3 /app-editors
parentapp-editors/xvile: drop 9.8w-r1 (diff)
downloadgentoo-7d6862b0cd7c79d091a057f2d51ad091d34a8cf4.tar.gz
gentoo-7d6862b0cd7c79d091a057f2d51ad091d34a8cf4.tar.bz2
gentoo-7d6862b0cd7c79d091a057f2d51ad091d34a8cf4.zip
app-editors/vile: add 9.8y
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vile/Manifest2
-rw-r--r--app-editors/vile/vile-9.8y.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/app-editors/vile/Manifest b/app-editors/vile/Manifest
index ddc6f2346725..87584730daa3 100644
--- a/app-editors/vile/Manifest
+++ b/app-editors/vile/Manifest
@@ -2,3 +2,5 @@ DIST vile-9.8w.tgz 2407322 BLAKE2B 824142c2d081db7c74ab4ce36db63e2d26e82954b32d2
DIST vile-9.8w.tgz.asc 729 BLAKE2B 24ee3733957239b808566cf1c46cd45089ab0e9cd980fc477190beca79a85e6d31925c8eb02138442e4776b7ee678aec9d522d4bb3a8d72670e0720ab9369a5c SHA512 143eaa6ea64cf1d8dc078aba197544a036858f91a15f2f8c4254095f7cdc725b1720cf600afcd3ba67cf0c0414cefb0a058a5730d1a70906fe3591ddc46fb916
DIST vile-9.8x.tgz 2476108 BLAKE2B a788f3a0544d2044e41aadd1d875ef62bd40179aa2090361a044862f0e7c801fdc8b0e3e71ae46c2406979babe499d5ed96fbf5f0ed87c2da1dbb0a3961f4f3b SHA512 099f38ffd58fb501b18a98b6be031cb51dc3c67f4d7f2e1b43763d4066d5b1f4e46d16e1d0302e437db6b4a27805c5696341e5a3da543adbde60211338732016
DIST vile-9.8x.tgz.asc 729 BLAKE2B 30d033ac048b88c74f6115eeb2c09984a438e60cc4ad291532bdd0789408b9a4c0734d0322588741da2d66562258a8cb7ba557f5c7e212a4219bc6b2719d1407 SHA512 2138a256e00e2d68e747c09579ed4c4d946f6337cc3b2b8763a775871afd9acb96f1562746347632dd021b0528f0e2143e1bcba3b1e583c685f58e9f19af543a
+DIST vile-9.8y.tgz 2477410 BLAKE2B 993f43a8e033e40d95c6d762daafebf328cae291380d448ec14b2a335569d5de7f628308433cb5abec15958bf1fc47c29f3f0ed49282f22cf7affd839c6ac2c6 SHA512 ce3c7178f6aecfd152e487d0053399739cf8880aa9c38283c9e4e7b95606fa2484f3cf9f7e797f538a47555be5257fbd34b112210e68a39d74f6b8ae7d968c32
+DIST vile-9.8y.tgz.asc 729 BLAKE2B 224cc75c025eb81b898990cb9f44a24e340664c658cead90f16d9103ed3bd3f15ce2c5dcf278c25f4a82069be2d39905f241c5d263b3170a731fb7e865cc45f7 SHA512 5475819801b6dcf3259811b5d3e29584a89baf574ca5685e61c6f98ba15c088ac6843bef66d2a9008b18fb4013fb40aa963ee48b15a786d6724f9ad7a599bd13
diff --git a/app-editors/vile/vile-9.8y.ebuild b/app-editors/vile/vile-9.8y.ebuild
new file mode 100644
index 000000000000..61938f85b696
--- /dev/null
+++ b/app-editors/vile/vile-9.8y.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Bump with app-editors/xvile
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="https://invisible-island.net/vile/"
+SRC_URI="https://invisible-island.net/archives/vile/current/${P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/vile/current/${P}.tgz.asc )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="perl iconv"
+
+RDEPEND=">=sys-libs/ncurses-5.2:=
+ virtual/libcrypt:=
+ iconv? ( virtual/libiconv )
+ perl? ( dev-lang/perl:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-alternatives/lex
+ virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-thomasdickey )
+"
+IDEPEND="app-eselect/eselect-vi"
+
+src_configure() {
+ econf \
+ --disable-stripping \
+ --with-ncurses \
+ --with-pkg-config \
+ $(use_with iconv) \
+ $(use_with perl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc CHANGES* README doc/*.doc
+ docinto html
+ dodoc doc/*.html
+}
+
+pkg_postinst() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}
+
+pkg_postrm() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}