summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-09 10:09:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-09 10:09:22 +0200
commit7face3ba46c499b467951a757bb22312ae33ad0b (patch)
treed96937d49f74dd4168e5fa0e3e205f20ff80f60d /app-editors
parentkde-misc/tellico: 3.1.3 version bump (diff)
downloadgentoo-7face3ba46c499b467951a757bb22312ae33ad0b.tar.gz
gentoo-7face3ba46c499b467951a757bb22312ae33ad0b.tar.bz2
gentoo-7face3ba46c499b467951a757bb22312ae33ad0b.zip
app-editors/okteta: 0.25.4 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/okteta/Manifest1
-rw-r--r--app-editors/okteta/okteta-0.25.4.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-editors/okteta/Manifest b/app-editors/okteta/Manifest
index c140a30f82f9..8135543bb969 100644
--- a/app-editors/okteta/Manifest
+++ b/app-editors/okteta/Manifest
@@ -1 +1,2 @@
DIST okteta-0.25.3.tar.xz 950956 BLAKE2B d177db59b5327f4e75157c99fdac2191de9a7ef63433635ccf8f11ef4dc4ff201942c9f68383d720b18c26a9e7335bc1181ea4f0e36491b34b27e6c7dc469c9e SHA512 f27b0c2ca3c5f1ad838af847e08c53c8f8f3c386921bd2e0d5e833902659477196e6c6b72a428443e2be9013928c2151c1889ef33d59404815a34d81560ef2a7
+DIST okteta-0.25.4.tar.xz 950344 BLAKE2B 3a3daf5cdb9e349e145a22afe836c78e18972e1f984472267cd182630b8f8132e10efb49cbc9fac40768aef4dadbb678afa26eb965642f07f407030f15b71dbd SHA512 d9887a90efbad3bb2caa0d3bb12af27708b77d54a90cd0da82eace7ea6dfc2efbcea3d7dc720bf4a088a823a8ed9edf75ab1c3680aa6d99c640d5c9e4c385e16
diff --git a/app-editors/okteta/okteta-0.25.4.ebuild b/app-editors/okteta/okteta-0.25.4.ebuild
new file mode 100644
index 000000000000..891f51eadc74
--- /dev/null
+++ b/app-editors/okteta/okteta-0.25.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Hex editor by KDE"
+HOMEPAGE="https://www.kde.org/applications/utilities/okteta
+https://utils.kde.org/projects/okteta"
+IUSE="crypt designer"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtscript 'scripttools')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ crypt? ( app-crypt/qca:2[qt5(+)] )
+ designer? ( $(add_qt_dep designer) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DOMIT_EXAMPLES=ON
+ $(cmake-utils_use_find_package crypt Qca-qt5)
+ -DBUILD_DESIGNERPLUGIN=$(usex designer)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ local myctestargs=( -j1 )
+
+ kde5_src_test
+}