summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-09-27 13:28:33 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-09-27 13:28:33 +0200
commitd150c22c354afa61f9777c65f075e58e8d6780b4 (patch)
tree7b1a0cc61fa92833a0bced27a5f9aca6cbc0da34 /app-editors
parentapache-2.eclass: Work around broken AC_ARG_ENABLE logic. (diff)
downloadgentoo-d150c22c354afa61f9777c65f075e58e8d6780b4.tar.gz
gentoo-d150c22c354afa61f9777c65f075e58e8d6780b4.tar.bz2
gentoo-d150c22c354afa61f9777c65f075e58e8d6780b4.zip
app-editors/nano: Added USE="minimal" build fix.
Closes: https://bugs.gentoo.org/667052 Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/files/nano-3.1-enable_tiny_build_fix.patch29
-rw-r--r--app-editors/nano/nano-3.1.ebuild6
2 files changed, 34 insertions, 1 deletions
diff --git a/app-editors/nano/files/nano-3.1-enable_tiny_build_fix.patch b/app-editors/nano/files/nano-3.1-enable_tiny_build_fix.patch
new file mode 100644
index 000000000000..58fe1982be9c
--- /dev/null
+++ b/app-editors/nano/files/nano-3.1-enable_tiny_build_fix.patch
@@ -0,0 +1,29 @@
+From 368ec04870a366b19f1c5801a6868786547968b0 Mon Sep 17 00:00:00 2001
+From: Benno Schulenberg <bensberg@telfort.nl>
+Date: Wed, 19 Sep 2018 20:36:39 +0200
+Subject: build: fix compilation again when configured with --enable-tiny
+
+Reported-by: Jordi Mallach <jordi@mallach.net>
+---
+ src/nano.c | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/src/nano.c b/src/nano.c
+index ebb1f11..01f92a1 100644
+--- a/src/nano.c
++++ b/src/nano.c
+@@ -1756,7 +1756,10 @@ int do_input(bool allow_funcs)
+ if (shortcut == NULL)
+ pletion_line = NULL;
+ else {
+- if (ISSET(VIEW_MODE) && shortcut->func != do_toggle_void &&
++ if (ISSET(VIEW_MODE) &&
++#ifndef NANO_TINY
++ shortcut->func != do_toggle_void &&
++#endif
+ !okay_for_view(shortcut)) {
+ print_view_warning();
+ return ERR;
+--
+cgit v1.0-41-gc330
+
diff --git a/app-editors/nano/nano-3.1.ebuild b/app-editors/nano/nano-3.1.ebuild
index 7f0d1d7bfbdc..a9712a1c464c 100644
--- a/app-editors/nano/nano-3.1.ebuild
+++ b/app-editors/nano/nano-3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,6 +31,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
static? ( ${LIB_DEPEND} )"
+PATCHES=(
+ "${FILESDIR}/${P}-enable_tiny_build_fix.patch"
+)
+
src_prepare() {
default
if [[ ${PV} == "9999" ]] ; then