summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/emhacks
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/emhacks')
-rw-r--r--app-emacs/emhacks/Manifest1
-rw-r--r--app-emacs/emhacks/emhacks-20070920.ebuild39
-rw-r--r--app-emacs/emhacks/files/50emhacks-gentoo.el32
-rw-r--r--app-emacs/emhacks/metadata.xml19
4 files changed, 91 insertions, 0 deletions
diff --git a/app-emacs/emhacks/Manifest b/app-emacs/emhacks/Manifest
new file mode 100644
index 000000000000..7fa6c2b158ea
--- /dev/null
+++ b/app-emacs/emhacks/Manifest
@@ -0,0 +1 @@
+DIST emhacks-20070920.tar.bz2 71232 SHA256 d249a6dfcb0e7b40c76844ee5959032ad0a792ff391ee11fe5e4a461c6b86ed7 SHA512 097a4602d82587a20feeb14c4717c69536336319f43f7b5e8b4ba0c7f878218138eddbe1edb6293222b7c5798b94dd2c8393231a7b8fb8f32fe5349f2b054bb1 WHIRLPOOL 7e876c0dd2e425da97ef3a721c86b49f2229c318bd35334cb9a9bdd1c2506f4e802c7e9d89e7ea38b35d1b781c38d8e2ca280bfceca2d0b5741fd45791548772
diff --git a/app-emacs/emhacks/emhacks-20070920.ebuild b/app-emacs/emhacks/emhacks-20070920.ebuild
new file mode 100644
index 000000000000..f072a1c1b122
--- /dev/null
+++ b/app-emacs/emhacks/emhacks-20070920.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Useful Emacs Lisp libraries, including gdiff, jjar, jmaker, swbuff, and tabbar"
+HOMEPAGE="http://emhacks.sourceforge.net/"
+# CVS snapshot
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jde"
+
+DEPEND="jde? ( app-emacs/jde )"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ # remove files included in Emacs>=22 or not useful on GNU/Linux
+ rm -r findstr* overlay-fix* recentf* ruler-mode* tree-widget* || die
+ # this requires jde and cedet, not everyone may want it
+ use jde || rm jsee.el || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+
+ cp "${FILESDIR}/${SITEFILE}" "${T}"
+ use jde || sed -i -e '/;; jsee/,$d' "${T}/${SITEFILE}"
+ elisp-site-file-install "${T}/${SITEFILE}"
+
+ dodoc Changelog
+}
diff --git a/app-emacs/emhacks/files/50emhacks-gentoo.el b/app-emacs/emhacks/files/50emhacks-gentoo.el
new file mode 100644
index 000000000000..14fd515ff685
--- /dev/null
+++ b/app-emacs/emhacks/files/50emhacks-gentoo.el
@@ -0,0 +1,32 @@
+(add-to-list 'load-path "@SITELISP@")
+
+;; dir-tree
+(autoload 'dir-tree "dir-tree"
+ "Display the ROOT directory in a tree widget." t)
+
+;; gdiff
+(require 'gdiff-setup)
+
+;; swbuff
+(autoload 'swbuff-switch-to-next-buffer "swbuff"
+ "Switch to the next buffer in the buffer list." t)
+(autoload 'swbuff-kill-this-buffer "swbuff"
+ "Kill the current buffer.
+And update the status window if showing." t)
+
+;; tabbar
+(autoload 'tabbar-local-mode "tabbar" nil t)
+(autoload 'tabbar-mode "tabbar" nil t)
+(autoload 'tabbar-mwheel-mode "tabbar" nil t)
+
+;; jjar
+(autoload 'jjar-create "jjar" "Create a new jar file." t)
+(autoload 'jjar-update "jjar" "Update an existing jar file." t)
+
+;; jmaker
+(autoload 'jmaker-generate-makefile "jmaker"
+ "Generate and edit a Java Makefile in directory ROOT." t)
+
+;; jsee
+(autoload 'jsee-browse-api-doc "jsee"
+ "Browse the Java API Documentation of the current Java file." t)
diff --git a/app-emacs/emhacks/metadata.xml b/app-emacs/emhacks/metadata.xml
new file mode 100644
index 000000000000..90f2f2e1f9a7
--- /dev/null
+++ b/app-emacs/emhacks/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ The EMHACKS project goal is to provide a set of useful libraries to help
+ using Emacs or XEmacs.
+
+ Among those libraries you will find:
+ gdiff, Use an external GUI diff tool from [X]Emacs;
+ jjar, Java Archive builder;
+ jmaker, Java Makefile generator;
+ swbuff, Quick switch between Emacs buffers;
+ tabbar, Display a tab bar in the header line.
+</longdescription>
+<use>
+ <flag name='jde'>Enable support for Java Development Environment</flag>
+</use>
+</pkgmetadata>