summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-07-04 14:45:24 +0200
committerUlrich Müller <ulm@gentoo.org>2021-07-04 14:45:24 +0200
commit6baf2ae8d8f2789b86d194edfe7d3bba35b41119 (patch)
tree6006231afb8013b141632af396f8cc8ee4d7ac90 /app-emacs/helm
parentapp-emacs/helm: Don't check for autoload file in emacs-helm.sh (diff)
downloadgentoo-6baf2ae8d8f2789b86d194edfe7d3bba35b41119.tar.gz
gentoo-6baf2ae8d8f2789b86d194edfe7d3bba35b41119.tar.bz2
gentoo-6baf2ae8d8f2789b86d194edfe7d3bba35b41119.zip
app-emacs/helm: Version bump to 3.8.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/helm')
-rw-r--r--app-emacs/helm/Manifest1
-rw-r--r--app-emacs/helm/files/helm-3.8.0-no-autoload-check.patch24
-rw-r--r--app-emacs/helm/helm-3.8.0.ebuild31
3 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/helm/Manifest b/app-emacs/helm/Manifest
index a9d7bbb9a011..aa4ada9dc40d 100644
--- a/app-emacs/helm/Manifest
+++ b/app-emacs/helm/Manifest
@@ -1,2 +1,3 @@
DIST helm-3.2.tar.gz 2285972 BLAKE2B b5385b805825d89ed87ba438ce830ce1e694cf842db590576b0ceaa2c110f5d0853b24211fdeebb77394c5ecca8460bcd52fe58240233ea10993504030328e9e SHA512 006e53f1984d38fa6305830179bc4ef04fa3007effa07685ddf479c1fbca547b6f8e99dd370f5653d57b2f8e519a54948a4730a0fdf9af8574cbfa27c09662d5
DIST helm-3.6.0.tar.gz 2302677 BLAKE2B e9a83a1a4f46c1256090ff458ffc3cb158aaa320a067fb1474c9f62bd0cceaf98c53191790113c8af228d8a47fc7d2585a528ffed3e6e06030a4308f9c65e095 SHA512 1cfaf5cdef9203bb92b80c684b21ec7ca92df00aa2e82815e8f39c623648232405273fb272244d7d2b2756f4699f82f93e9a669a13a71da9410f0c0f9df30393
+DIST helm-3.8.0.tar.gz 3943168 BLAKE2B cee9ed8eafdf01cb2109dcf5289522f4a0d9db9a8626097a1ffc3bdeaee792b072b7b27e635ef360815a354c9796b55fc4b3921784e2fd0d655387507df208b6 SHA512 0aec3d4270205c61cabc991dd39d5bac3b10e827f362819e9fb85880985ce2c7e7c7b8f73d2f0cde5b5c168d4b9857e0379f1e4ca9395dbd8f083c1a707ad3f2
diff --git a/app-emacs/helm/files/helm-3.8.0-no-autoload-check.patch b/app-emacs/helm/files/helm-3.8.0-no-autoload-check.patch
new file mode 100644
index 000000000000..4b415088dcc6
--- /dev/null
+++ b/app-emacs/helm/files/helm-3.8.0-no-autoload-check.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/800177
+
+--- helm-3.8.0/emacs-helm.sh
++++ helm-3.8.0/emacs-helm.sh
+@@ -137,19 +137,6 @@
+
+ cd "${0%/*}" || exit 1
+
+-# Check if autoload file exists.
+-# It may be in a different directory if emacs-helm.sh is a symlink.
+-TRUENAME=$(ls -l "$0" | awk '{print $11}')
+-if [ ! -z "$TRUENAME" ]; then
+- AUTO_FILE="${TRUENAME%/*}/helm-autoloads.el"
+-else
+- AUTO_FILE="helm-autoloads.el"
+-fi
+-if [ ! -e "$AUTO_FILE" ]; then
+- echo No autoloads found, please run make first to generate autoload file
+- exit 1
+-fi
+-
+
+ cat > $CONF_FILE <<EOF
+ (setq initial-scratch-message (concat initial-scratch-message
diff --git a/app-emacs/helm/helm-3.8.0.ebuild b/app-emacs/helm/helm-3.8.0.ebuild
new file mode 100644
index 000000000000..6103dff04df4
--- /dev/null
+++ b/app-emacs/helm/helm-3.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/async
+ app-emacs/popup"
+BDEPEND="${RDEPEND}"
+
+PATCHES="${FILESDIR}/${P}-no-autoload-check.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+ dobin emacs-helm.sh
+}