summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-01-21 17:41:31 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-01-21 17:42:48 +0100
commit61d5f30bff79d725a02660bafe72d8a5187b564b (patch)
treec525932f2250e3823297c8b630c959f6a8bcb23b /app-emacs/lean-mode/lean-mode-20211220.ebuild
parentdev-java/j2objc-annotations: re-added arm (diff)
downloadgentoo-61d5f30bff79d725a02660bafe72d8a5187b564b.tar.gz
gentoo-61d5f30bff79d725a02660bafe72d8a5187b564b.tar.bz2
gentoo-61d5f30bff79d725a02660bafe72d8a5187b564b.zip
app-emacs/lean-mode: new package; add version 20211220
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/lean-mode/lean-mode-20211220.ebuild')
-rw-r--r--app-emacs/lean-mode/lean-mode-20211220.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/lean-mode/lean-mode-20211220.ebuild b/app-emacs/lean-mode/lean-mode-20211220.ebuild
new file mode 100644
index 000000000000..c7be99f3162a
--- /dev/null
+++ b/app-emacs/lean-mode/lean-mode-20211220.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=a4205749d20a09871f0951c34f919d4ee5fbdb55
+NEED_EMACS=24.3
+
+inherit elisp
+
+DESCRIPTION="Emacs mode for the Lean 3 theorem prover"
+HOMEPAGE="https://github.com/leanprover/lean-mode/"
+SRC_URI="https://github.com/leanprover/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${H}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=app-emacs/dash-2.18.1
+ >=app-emacs/f-0.19.0
+ >=app-emacs/flycheck-32
+ >=app-emacs/s-1.10.0
+"
+RDEPEND="
+ ${DEPEND}
+ sci-mathematics/lean:0/3
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ rm {company,helm}-lean.el || die
+
+ elisp_src_prepare
+}