summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-06-06 00:10:25 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-06-06 00:57:15 +0200
commitf507414bacf6077d0fff4371a0ca268f111f1fc2 (patch)
treeda82bcf4388cdadf9b92fad56b752c22a483d50c /app-emacs/lean-mode/lean-mode-20220501.ebuild
parentapp-emacs/lean-mode: DEPEND -> BDEPEND (diff)
downloadgentoo-f507414bacf6077d0fff4371a0ca268f111f1fc2.tar.gz
gentoo-f507414bacf6077d0fff4371a0ca268f111f1fc2.tar.bz2
gentoo-f507414bacf6077d0fff4371a0ca268f111f1fc2.zip
app-emacs/lean-mode: bump to 20220501
2022.05.01 snapshot Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/lean-mode/lean-mode-20220501.ebuild')
-rw-r--r--app-emacs/lean-mode/lean-mode-20220501.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/lean-mode/lean-mode-20220501.ebuild b/app-emacs/lean-mode/lean-mode-20220501.ebuild
new file mode 100644
index 000000000000..34d78fe6a7fc
--- /dev/null
+++ b/app-emacs/lean-mode/lean-mode-20220501.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=362bc6fa3efb1874c525ed6b4b6f24f76af22596
+NEED_EMACS=24.3
+
+inherit elisp
+
+DESCRIPTION="Emacs mode for the Lean 3 theorem prover"
+HOMEPAGE="https://github.com/leanprover/lean-mode/"
+SRC_URI="https://github.com/leanprover/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ >=app-emacs/dash-2.18.1
+ >=app-emacs/f-0.19.0
+ >=app-emacs/flycheck-32
+ >=app-emacs/s-1.10.0
+"
+RDEPEND="
+ ${BDEPEND}
+ sci-mathematics/lean:0/3
+"
+
+DOCS=( README.md )
+ELISP_REMOVE="company-lean.el helm-lean.el"
+SITEFILE="50${PN}-gentoo.el"