summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-06-19 12:48:34 +0100
committerMatthew Smith <matthew@gentoo.org>2022-06-19 12:55:57 +0100
commit4ce742f40797ee20d1da425dd80552f3be901912 (patch)
tree56537824809aebcade6f4d45c9d17fd3e97cb3d2 /app-emacs/setup/setup-1.3.0.ebuild
parentnet-im/skypeforlinux: drop 8.79.0.95 (diff)
downloadgentoo-4ce742f40797ee20d1da425dd80552f3be901912.tar.gz
gentoo-4ce742f40797ee20d1da425dd80552f3be901912.tar.bz2
gentoo-4ce742f40797ee20d1da425dd80552f3be901912.zip
app-emacs/setup: add 1.3.0
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'app-emacs/setup/setup-1.3.0.ebuild')
-rw-r--r--app-emacs/setup/setup-1.3.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/setup/setup-1.3.0.ebuild b/app-emacs/setup/setup-1.3.0.ebuild
new file mode 100644
index 000000000000..364818701e67
--- /dev/null
+++ b/app-emacs/setup/setup-1.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=26
+
+# The upstream does not create git tags for releases.
+MY_HASH=eece09d1151fd641f31d738b8c62742918993e95
+
+inherit elisp
+
+DESCRIPTION="Macro to simplify repetitive configuration patterns"
+HOMEPAGE="https://git.sr.ht/~pkal/setup"
+SRC_URI="https://git.sr.ht/~pkal/${PN}/archive/${MY_HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_HASH}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}