summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-30 15:01:59 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-30 15:02:19 +0200
commit6db93e1d0aa08604dbf542595494f1bdf511c34b (patch)
tree4f3a7102330e57df84a683dfe42e7ba65bbef723 /app-emacs/webpaste/webpaste-3.2.2.ebuild
parentgames-misc/bsd-games: Keyword 3.1-r2 mips, #841230 (diff)
downloadgentoo-6db93e1d0aa08604dbf542595494f1bdf511c34b.tar.gz
gentoo-6db93e1d0aa08604dbf542595494f1bdf511c34b.tar.bz2
gentoo-6db93e1d0aa08604dbf542595494f1bdf511c34b.zip
app-emacs/webpaste: new package; add version 3.2.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/webpaste/webpaste-3.2.2.ebuild')
-rw-r--r--app-emacs/webpaste/webpaste-3.2.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/webpaste/webpaste-3.2.2.ebuild b/app-emacs/webpaste/webpaste-3.2.2.ebuild
new file mode 100644
index 000000000000..1d7054734a31
--- /dev/null
+++ b/app-emacs/webpaste/webpaste-3.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp
+
+DESCRIPTION="Paste parts of buffers to several pastebin-like services from Emacs"
+HOMEPAGE="https://github.com/etu/webpaste.el/"
+SRC_URI="https://github.com/etu/${PN}.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${PV}
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-emacs/request"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/buttercup )
+"
+
+DOCS=( README.org )
+# Remove failing tests
+ELISP_REMOVE="tests/unit/test-webpaste-provider-creation.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ buttercup -L . -L tests tests/unit || die
+}