summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-02-15 15:26:52 +0100
committerUlrich Müller <ulm@gentoo.org>2022-02-15 15:51:43 +0100
commit5d02a82e15e053460d831b1ac528bc97e3d18063 (patch)
treeace3fa2b653f5ad2b683f7f4f66861bdb3c4f5f2 /app-emacs/websocket/websocket-1.13.ebuild
parentnet-fs/cifs-utils: introduce python USE flag (diff)
downloadgentoo-5d02a82e15e053460d831b1ac528bc97e3d18063.tar.gz
gentoo-5d02a82e15e053460d831b1ac528bc97e3d18063.tar.bz2
gentoo-5d02a82e15e053460d831b1ac528bc97e3d18063.zip
app-emacs/websocket: Version bump to 1.13
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/websocket/websocket-1.13.ebuild')
-rw-r--r--app-emacs/websocket/websocket-1.13.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/websocket/websocket-1.13.ebuild b/app-emacs/websocket/websocket-1.13.ebuild
new file mode 100644
index 000000000000..d222795cdb0b
--- /dev/null
+++ b/app-emacs/websocket/websocket-1.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A websocket implementation in elisp"
+HOMEPAGE="https://github.com/ahyatt/emacs-websocket"
+SRC_URI="https://github.com/ahyatt/emacs-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/emacs-${P}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile websocket.el
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l websocket-test \
+ -f ert-run-tests-batch-and-exit
+}
+
+src_install() {
+ elisp-install ${PN} websocket.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc README.org websocket-functional-test.el testserver.py
+}