summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-06-03 10:06:32 -0400
committerAaron Bauman <bman@gentoo.org>2018-06-03 21:12:19 -0400
commitad4ab77e9c888b6f299067f2ea89daac7459dcec (patch)
tree62e3480aa614b22faa058b6f0b8f558c9b4735ac /app-emacs/yasnippet/yasnippet-0.6.1c.ebuild
parentmedia-sound/clementine: 1.3.1_p20180523 snapshot bump (diff)
downloadgentoo-ad4ab77e9c888b6f299067f2ea89daac7459dcec.tar.gz
gentoo-ad4ab77e9c888b6f299067f2ea89daac7459dcec.tar.bz2
gentoo-ad4ab77e9c888b6f299067f2ea89daac7459dcec.zip
app-emacs/yasnippet: drop old EAPI
Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8715
Diffstat (limited to 'app-emacs/yasnippet/yasnippet-0.6.1c.ebuild')
-rw-r--r--app-emacs/yasnippet/yasnippet-0.6.1c.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/app-emacs/yasnippet/yasnippet-0.6.1c.ebuild b/app-emacs/yasnippet/yasnippet-0.6.1c.ebuild
deleted file mode 100644
index 831ffed191b4..000000000000
--- a/app-emacs/yasnippet/yasnippet-0.6.1c.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit elisp
-
-DESCRIPTION="Yet another snippet extension for Emacs"
-HOMEPAGE="https://github.com/capitaomorte/yasnippet"
-SRC_URI="https://yasnippet.googlecode.com/files/${P}.tar.bz2
- doc? ( https://yasnippet.googlecode.com/files/${PN}-doc-${PV}.tar.bz2 )"
-
-# Homepage says MIT licence, source contains GPL-2 copyright notice
-LICENSE="MIT GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND=">=app-emacs/dropdown-list-20080316"
-RDEPEND="${DEPEND}"
-
-SITEFILE="50${PN}-gentoo.el"
-
-src_unpack() {
- elisp_src_unpack
-
- # remove bundled copy of dropdown-list
- rm "${S}/dropdown-list.el" || die
-}
-
-src_install() {
- elisp_src_install
-
- insinto "${SITEETC}/${PN}"
- doins -r snippets || die "doins failed"
-
- if use doc; then
- dohtml -r "${WORKDIR}"/doc/* || die "dohtml failed"
- fi
-}
-
-pkg_postinst() {
- elisp-site-regen
-
- elog "Please add the following code into your .emacs to use yasnippet:"
- elog "(yas/initialize)"
- elog "(yas/load-directory \"${SITEETC}/${PN}/snippets\")"
-}