summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-08-10 08:22:02 +0200
committerUlrich Müller <ulm@gentoo.org>2018-08-10 08:22:41 +0200
commit5e3ee0a508a71cbc4090d86e09e3a5c124566034 (patch)
tree66c04ab6d3c54449f089d1cac27c75c364472b25 /app-emacs
parentapp-emacs/vm: Depend on <app-emacs/bbdb-3. (diff)
downloadgentoo-5e3ee0a508a71cbc4090d86e09e3a5c124566034.tar.gz
gentoo-5e3ee0a508a71cbc4090d86e09e3a5c124566034.tar.bz2
gentoo-5e3ee0a508a71cbc4090d86e09e3a5c124566034.zip
app-emacs/vm: Fix function definition in vm-pcrisis.el.
Bug: https://bugs.gentoo.org/652952 Package-Manager: Portage-2.3.45, Repoman-2.3.10
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/vm/files/vm-8.2.0_beta-optional-args.patch13
-rw-r--r--app-emacs/vm/vm-8.2.0_beta-r1.ebuild (renamed from app-emacs/vm/vm-8.2.0_beta.ebuild)18
2 files changed, 22 insertions, 9 deletions
diff --git a/app-emacs/vm/files/vm-8.2.0_beta-optional-args.patch b/app-emacs/vm/files/vm-8.2.0_beta-optional-args.patch
new file mode 100644
index 000000000000..2cec28e046fd
--- /dev/null
+++ b/app-emacs/vm/files/vm-8.2.0_beta-optional-args.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/652952
+
+--- vm-8.2.0b-orig/lisp/vm-pcrisis.el
++++ vm-8.2.0b/lisp/vm-pcrisis.el
+@@ -1214,7 +1214,7 @@
+ ;; Functions for vmpc-conditions:
+ ;; -------------------------------------------------------------------
+
+-(defun vmpc-none-true-yet (&optional &rest exceptions)
++(defun vmpc-none-true-yet (&rest exceptions)
+ "True if none of the previous evaluated conditions was true.
+ This is a condition that can appear in `vmpc-conditions'. If EXCEPTIONS are
+ specified, it means none were true except those. For example, if you wanted
diff --git a/app-emacs/vm/vm-8.2.0_beta.ebuild b/app-emacs/vm/vm-8.2.0_beta-r1.ebuild
index 2ed8bc2e6aab..0cdf2674f889 100644
--- a/app-emacs/vm/vm-8.2.0_beta.ebuild
+++ b/app-emacs/vm/vm-8.2.0_beta-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit elisp eutils
+inherit elisp
MY_PV="${PV/_beta/b}"
MY_P="${PN}-${MY_PV}"
@@ -17,22 +17,22 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE="bbdb ssl"
DEPEND="bbdb? ( <app-emacs/bbdb-3 )"
-RDEPEND="!app-emacs/u-vm-color
- ${DEPEND}
+RDEPEND="${DEPEND}
ssl? ( net-misc/stunnel )"
-DEPEND="${DEPEND}
- sys-apps/texinfo"
+BDEPEND="sys-apps/texinfo"
S="${WORKDIR}/${MY_P}"
SITEFILE="50${PN}-gentoo.el"
src_prepare() {
- epatch "${FILESDIR}/${P}-datadir.patch"
- epatch "${FILESDIR}/${P}-texinfo-5.patch"
+ eapply "${FILESDIR}/${P}-datadir.patch"
+ eapply "${FILESDIR}/${P}-texinfo-5.patch"
+ eapply "${FILESDIR}/${P}-optional-args.patch"
+ eapply_user
if ! use bbdb; then
elog "Excluding vm-pcrisis.el since the \"bbdb\" USE flag is not set."
- epatch "${FILESDIR}/${PN}-8.0-no-pcrisis.patch"
+ eapply "${FILESDIR}/${PN}-8.0-no-pcrisis.patch"
fi
}