summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-05-25 16:04:28 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-05-25 16:04:35 -0500
commite90767c9ddb79ea1945a649959635e0a9187b93e (patch)
treebde15d58e0290047fb4ae508b38e43ffe3acc701 /app-emulation/diskimage-builder/diskimage-builder-2.37.0.ebuild
parentmedia-gfx/cura: works with py38 (diff)
downloadgentoo-e90767c9ddb79ea1945a649959635e0a9187b93e.tar.gz
gentoo-e90767c9ddb79ea1945a649959635e0a9187b93e.tar.bz2
gentoo-e90767c9ddb79ea1945a649959635e0a9187b93e.zip
app-emulation/diskimage-builder: 2.37.0 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation/diskimage-builder/diskimage-builder-2.37.0.ebuild')
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-2.37.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.37.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.37.0.ebuild
new file mode 100644
index 000000000000..720474e33c48
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-2.37.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"