summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-05-01 11:52:52 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-05-01 11:54:21 -0500
commit5abb12c3fe4a792549aa9642b6ebcd5ea6e913bb (patch)
treebd14920bfa95a23062bbe59b77eddd5651aee1ca /app-emulation/diskimage-builder/diskimage-builder-3.11.0.ebuild
parentsys-auth/AusweisApp2: drop old version (diff)
downloadgentoo-5abb12c3fe4a792549aa9642b6ebcd5ea6e913bb.tar.gz
gentoo-5abb12c3fe4a792549aa9642b6ebcd5ea6e913bb.tar.bz2
gentoo-5abb12c3fe4a792549aa9642b6ebcd5ea6e913bb.zip
app-emulation/diskimage-builder: 3.10.0 stable amd64/x86 with cleanup
3.11.0 bump too Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation/diskimage-builder/diskimage-builder-3.11.0.ebuild')
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.11.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.11.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.11.0.ebuild
new file mode 100644
index 000000000000..4c39e9fb0b8c
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.11.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"