summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-10-10 12:15:52 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-10-10 12:28:17 -0500
commit8e963392115b74b9aba406434140f2485215138b (patch)
treee6636b74623eceaabf2c429108e81653e34d73e1 /app-emulation/diskimage-builder
parentdev-util/rej: EAPI=7 (diff)
downloadgentoo-8e963392115b74b9aba406434140f2485215138b.tar.gz
gentoo-8e963392115b74b9aba406434140f2485215138b.tar.bz2
gentoo-8e963392115b74b9aba406434140f2485215138b.zip
app-emulation/diskimage-builder: 2.28.0 bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation/diskimage-builder')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-2.28.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 5687436efe1d..9f79e4bfe919 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1,2 +1,3 @@
DIST diskimage-builder-2.26.1.tar.gz 421821 BLAKE2B 11c0ba668494285f33f3461e1a2c091ce6d622e4be164c4ab56a93cd000c82cec6702a6ed2ae37007120320f053760473f45f58ad8b45ee14b7b3eb47ac82d9a SHA512 e8bb68d15fc0bdd4881e76a7277f3e5e481b77decb4591546a576eda015bf624da3746326735add299551e168b82ab8bb165a18a64e96532c5b846e49815528f
DIST diskimage-builder-2.27.2.tar.gz 421433 BLAKE2B 089e68b07c6f79e54b8fb30e7a9328a6c55d1abb5f77b6592cc0b29b30a44a83803bdde93631e95e39d7fc82d9b5ff3fb425a7b94821b96f56421cbde9f8b078 SHA512 e2cc6f24d5bbfdf741d6b6e7e216d0e9631d6394cf3f3f4d34ce8a78ba2ba2ddbcb0b1434121f7ab1bd3600194777a5538651d9039c3bca06bb8cc621f06f037
+DIST diskimage-builder-2.28.0.tar.gz 425808 BLAKE2B f3cceec35f019b248df8aaa94f70231dc51a9fed06cf93b16366536cfcf45b4477b7aa09371bb3cffe95f51c74d0abf9065285b7b74c5d805604c2b00df8f38f SHA512 6eddef513e8550fb6f90e917a504bac1166ef4355791bd9b0c10addebb8f84b783bf4e53dd472e6ed9acb5d3dcd951e675f4e9983ec4170c31afdb257b84e24d
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.28.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.28.0.ebuild
new file mode 100644
index 000000000000..86d3bb124b34
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-2.28.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ <dev-python/networkx-2.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"