summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-01-04 13:59:42 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-01-04 13:59:42 +0100
commit6ccf35128789d12b4ee1fbfcb6d7dce31a93c048 (patch)
tree6655af42fb7af76dcecd86d8d548c6d2f7122c0b /app-emulation/docker-compose
parentapp-crypt/gnupg: Fix CNAME dns regression introduced in 2.1.17 (diff)
downloadgentoo-6ccf35128789d12b4ee1fbfcb6d7dce31a93c048.tar.gz
gentoo-6ccf35128789d12b4ee1fbfcb6d7dce31a93c048.tar.bz2
gentoo-6ccf35128789d12b4ee1fbfcb6d7dce31a93c048.zip
app-emulation/docker-compose: Add new snapshot supporting compose version 3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-emulation/docker-compose')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.10.0_pre20161220.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index dbcebca5005f..30c205a2b258 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -1,2 +1,3 @@
+DIST docker-compose-1.10.0_pre20161220.tar.gz 219218 SHA256 3e5e0a4dbe52979f32170e9572a6574ff0de97969fdc647f013f8ad4b383aa4f SHA512 5c6ad437228916d8ae713a553c73b9aeb10302fd4ea21b01911718f593eacd6b6a9c439a9a239f754daaafda6363a67300f60b5d9cb820679574b3a3b6a2df75 WHIRLPOOL da8b85e9275c716083b1688cbc067da26e6547bc9fe5eb90ced191f1313830fe7ffa25ad67b4f4cff9534425bbc3224ba80d6bc6d5087128b52af8fa4ad09a5f
DIST docker-compose-1.8.1.tar.gz 151478 SHA256 1c72725a0a5cd41f56021cb51c6cba86932fb5b4155378ce883500d2644efc84 SHA512 8b33bf5b1fa3eeb5c5724e7ada8c61cf054a5cc1af68c9c9ab40955958f0f6a537f5bad8d54367dddc5ae66930d0555c83da47a48fc43f623d92fd60ad01cb62 WHIRLPOOL 5dca7ff3303833a45b0e7f462a375c58f68f4a19659e66b93bfc564701df8dfba70311151eb674a84c5a3b81703ddcc8809c6c7b89574c738ac9db96a32c93e6
DIST docker-compose-1.9.0.tar.gz 156392 SHA256 98fb664c79c06a0777af2540b83eaa63c6a05ae7eb9e7417193899df2f96e27f SHA512 9d145807406ce4de3e91245bba4f774d80e0a39a81115fc111624e1a56b7e8a7505d49700df68b062efc65f8de661c8dca08067615a7504b3d7adf6c15d156d0 WHIRLPOOL ca64f1e8e9c830c3cab01193be0d809cbb80fbea2a451dd7f51ff688d76a376a047bdc781471b292de06a275f933ebf755c4b24cc60fe19fe77fb4729101b9e5
diff --git a/app-emulation/docker-compose/docker-compose-1.10.0_pre20161220.ebuild b/app-emulation/docker-compose/docker-compose-1.10.0_pre20161220.ebuild
new file mode 100644
index 000000000000..99967066a2cd
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.10.0_pre20161220.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit bash-completion-r1 distutils-r1 vcs-snapshot
+
+GIT_COMMIT="09690e1758d39f1213a9f44ab027ad69e1de0653"
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="https://github.com/docker/compose/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/cached-property-2[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ <dev-python/dockerpty-0.5[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.0.0[${PYTHON_USEDEP}]
+ <dev-python/docker-py-3.0[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ <dev-python/docopt-0.7[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-4[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+ <dev-python/requests-2.12[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.8.1[${PYTHON_USEDEP}]
+ <dev-python/texttable-0.9[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '<dev-python/enum34-2[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ ${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ ${PYTHON} -m pytest tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}