summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Ziak <0xe2.0x9a.0x9b@gmail.com>2018-05-12 15:14:26 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-12 17:55:25 +0200
commit7560e37a246dc3ca5589dff29d144962067c9c72 (patch)
tree0a3679e68a5ab27408c0b39f027119e5bc613fdd /app-emulation/fuse
parentapp-emulation/libspectrum: bump to version 1.4.2 (diff)
downloadgentoo-7560e37a246dc3ca5589dff29d144962067c9c72.tar.gz
gentoo-7560e37a246dc3ca5589dff29d144962067c9c72.tar.bz2
gentoo-7560e37a246dc3ca5589dff29d144962067c9c72.zip
app-emulation/fuse: bump to version 1.5.3
Diffstat (limited to 'app-emulation/fuse')
-rw-r--r--app-emulation/fuse/Manifest1
-rw-r--r--app-emulation/fuse/fuse-1.5.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-emulation/fuse/Manifest b/app-emulation/fuse/Manifest
index 9abfc1e77521..a2acc3e6f19c 100644
--- a/app-emulation/fuse/Manifest
+++ b/app-emulation/fuse/Manifest
@@ -1,2 +1,3 @@
DIST fuse-1.5.1.tar.gz 1623081 BLAKE2B 4b6cf747d15bc2d33a0baba88254a08187e8a615564236835da19d32f9afb312d5a5c90ac07a88d904019626b153546ecd8cd09b88fa16731af94ea54cd0e346 SHA512 d5f5b8a0e61f298a955450de208b29f8ab4fc0133c5c58e596f36f3834c088c946e19d7437dd1a6e73a89d32dcaf6ca9ce0fed8ec310c37aa6a6568be482abe4
DIST fuse-1.5.2.tar.gz 1626746 BLAKE2B 38236b9457e975fe227e2a19ed0fb80cac022fbb0bd8fcb1e51666103c4abe8960b1bd166fc1d12ab4e0f32954f7c3f59625d57d456313f75ca023bf51477e0b SHA512 45507834eb70d1e74c8f58017f4ae0bb54e2560456eeadfa8b6888a1c79e9c9443cccb7ae9733b96a895f94040be820c57a7d698115c2f483e64ebc4fd734268
+DIST fuse-1.5.3.tar.gz 1627487 BLAKE2B d942f0131ce713e8592abec6443015aca3f1ae73739f1db0eae84a19e4320fd8bffbd7d36afaf65b08cf059305f85a8854d39d46519ed7abd3705b11156d069c SHA512 6596f789a685c46752c46b2432953c0d9abb620b23541cdbfc066c224fcba47ac7be75db678e2ff76622a7d02cc81b7dfeae672dfdaee1085d2ae5f768a4d8c0
diff --git a/app-emulation/fuse/fuse-1.5.3.ebuild b/app-emulation/fuse/fuse-1.5.3.ebuild
new file mode 100644
index 000000000000..3bccba054d38
--- /dev/null
+++ b/app-emulation/fuse/fuse-1.5.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Free Unix Spectrum Emulator by Philip Kendall"
+HOMEPAGE="http://fuse-emulator.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa ao backend-fbcon backend-sdl backend-svga backend-X gpm joystick memlimit png xml"
+
+# Only one UI back-end can be enabled at a time
+REQUIRED_USE="?? ( backend-fbcon backend-sdl backend-svga backend-X )"
+
+RDEPEND="
+ >=app-emulation/libspectrum-1.4.2
+ dev-libs/glib:2
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ backend-sdl? ( media-libs/libsdl )
+ backend-svga? ( media-libs/svgalib )
+ backend-X? ( x11-libs/libX11 x11-libs/libXext )
+ !backend-fbcon? ( !backend-sdl? ( !backend-svga? ( !backend-X? ( x11-libs/gtk+:3 ) ) ) )
+ gpm? ( sys-libs/gpm )
+ joystick? ( media-libs/libjsw )
+ png? ( media-libs/libpng:0= sys-libs/zlib )
+ xml? ( dev-libs/libxml2:2 )"
+DEPEND="${RDEPEND}
+ backend-fbcon? ( virtual/linux-sources )
+ dev-lang/perl
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README THANKS )
+
+src_configure() {
+ local myconf=(
+ --without-win32
+ $(use_with alsa)
+ $(use_with ao libao)
+ $(use_with gpm)
+ $(use_with joystick)
+ $(use_enable joystick ui-joystick)
+ $(use_enable memlimit smallmem)
+ $(use_with png)
+ $(use_with xml libxml2)
+ )
+
+ if use backend-sdl; then
+ myconf+=("--with-sdl")
+ elif use backend-X; then
+ myconf+=("--without-gtk")
+ elif use backend-svga; then
+ myconf+=("--with-svgalib")
+ elif use backend-fbcon; then
+ myconf+=("--with-fb")
+ else
+ myconf+=("--with-gtk")
+ fi
+
+ econf "${myconf[@]}"
+}