summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-05-15 14:49:00 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-05-15 14:49:11 +0100
commitd4ec38dbe639f0a389e0c14eb03bfa55f549e26b (patch)
tree22e3f7d016ee8bb429fe7a0ba433d85a0e505e73 /app-emulation/ganeti-htools
parentdev-vcs/darcs: increase text lower bound up to 1.2.1.3 (needed by ghc-7.10) (diff)
downloadgentoo-d4ec38dbe639f0a389e0c14eb03bfa55f549e26b.tar.gz
gentoo-d4ec38dbe639f0a389e0c14eb03bfa55f549e26b.tar.bz2
gentoo-d4ec38dbe639f0a389e0c14eb03bfa55f549e26b.zip
app-emulation/ganeti-htools: fix testsuite against ghc-7.10
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-emulation/ganeti-htools')
-rw-r--r--app-emulation/ganeti-htools/files/ganeti-htools-0.3.1-containers.patch9
-rw-r--r--app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild1
2 files changed, 10 insertions, 0 deletions
diff --git a/app-emulation/ganeti-htools/files/ganeti-htools-0.3.1-containers.patch b/app-emulation/ganeti-htools/files/ganeti-htools-0.3.1-containers.patch
new file mode 100644
index 000000000000..2305aa5c6547
--- /dev/null
+++ b/app-emulation/ganeti-htools/files/ganeti-htools-0.3.1-containers.patch
@@ -0,0 +1,9 @@
+diff --git a/Ganeti/HTools/QC.hs b/Ganeti/HTools/QC.hs
+index 534a7b1..6f99a96 100644
+--- a/Ganeti/HTools/QC.hs
++++ b/Ganeti/HTools/QC.hs
+@@ -753,3 +753,3 @@ prop_ClusterAllocBalance node =
+ let nl = makeSmallCluster node count
+- (hnode, nl') = IntMap.deleteFindMax nl
++ ((_k, hnode), nl') = IntMap.deleteFindMax nl
+ il = Container.empty
diff --git a/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild b/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild
index 68482c2ee89c..2f51b83ff780 100644
--- a/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild
+++ b/app-emulation/ganeti-htools/ganeti-htools-0.3.1.ebuild
@@ -34,6 +34,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-0.2.8-use-QC-1.patch #316629
epatch "${FILESDIR}"/${PN}-0.3.1-base-4.patch #424299
epatch "${FILESDIR}"/${PN}-0.3.1-ghc-7.10.patch
+ epatch "${FILESDIR}"/${PN}-0.3.1-containers.patch
}
src_compile() {