summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emulation/ganeti-instance-debootstrap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emulation/ganeti-instance-debootstrap')
-rw-r--r--app-emulation/ganeti-instance-debootstrap/Manifest3
-rw-r--r--app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.11.ebuild35
-rw-r--r--app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.12.ebuild35
-rw-r--r--app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.9.ebuild35
-rw-r--r--app-emulation/ganeti-instance-debootstrap/metadata.xml12
5 files changed, 120 insertions, 0 deletions
diff --git a/app-emulation/ganeti-instance-debootstrap/Manifest b/app-emulation/ganeti-instance-debootstrap/Manifest
new file mode 100644
index 000000000000..2ad664a1d263
--- /dev/null
+++ b/app-emulation/ganeti-instance-debootstrap/Manifest
@@ -0,0 +1,3 @@
+DIST ganeti-instance-debootstrap-0.11.tar.gz 67946 SHA256 a80dcffe530473d935a1b14de940c8d437d5bf83dd8a5670d8b7d349f2e91768 SHA512 d39ae29b49e3e0e25e9052ee5201d5aeeedfa229cc0b8674ea01a26b1b615b262c1464ca16b5268884a0fa28981e5126eec084d7bb9298a4b405574925b85b4e WHIRLPOOL 860cd9c757e6b25d7caab5a8706e7f0705ae6c0a01b69bc7513060ce77ea7ea3903c6e00981825f341a0ea40f770744b6c6b3ae5c5bd472df045ac40e28b66b8
+DIST ganeti-instance-debootstrap-0.12.tar.gz 69835 SHA256 c9c516d72ad6581e06c40230ee2d811e8484c03b2542f7610c603a9460ef717e SHA512 5f1813510071addca9bee5e36f7b34a5cbd06f53db8222f6345cb788af8d686aeb94d11ec098eb63b8e11ded18a03c233dd99237f2db9190894bab6189353ab5 WHIRLPOOL ada2c9acb41c6d7a611a6dc9c574a83f7281e262c2cf4c73d70907c598dc209dc161e922d112b048728a118b2c19ffc8e3e12852f074eebf20ec5aec78b570fc
+DIST ganeti-instance-debootstrap-0.9.tar.gz 67353 SHA256 2ee275e349f1949d6483e1675e9ef9c39dd0bd7b051ac199176671b82e99c9cb SHA512 662ae950a7f7f34d2d1f00b49c1b45dd2fa422f922f230f5cc11f95a00eaccc1bf0c468346463dc66f11980262c8151933f8348676ea84ea4114afcc4600015b WHIRLPOOL a62e93a5293ed91917678db0be3c0c3f81b31550bdd1820a3701ed7236a972381a8371ff00f7db29eedffde6bbd47d4d623c3e018d820ed0c19679e292e41282
diff --git a/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.11.ebuild b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.11.ebuild
new file mode 100644
index 000000000000..73b43f8256b0
--- /dev/null
+++ b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Scripts to build Ganeti VMs with debootstrap"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/ganeti-instance-debootstrap-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/dpkg
+ app-arch/dump
+ app-emulation/ganeti
+ dev-util/debootstrap
+ >=sys-apps/coreutils-6.10-r1
+ sys-apps/util-linux
+ sys-fs/e2fsprogs"
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${P} || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ insinto /etc/ganeti/instance-debootstrap/hooks
+ doins examples/hooks/*
+}
diff --git a/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.12.ebuild b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.12.ebuild
new file mode 100644
index 000000000000..65cb9357eddd
--- /dev/null
+++ b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Scripts to build Ganeti VMs with debootstrap"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/ganeti-instance-debootstrap-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/dpkg
+ app-arch/dump
+ app-emulation/ganeti
+ dev-util/debootstrap
+ >=sys-apps/coreutils-6.10-r1
+ sys-apps/util-linux
+ sys-fs/e2fsprogs"
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${P} || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ insinto /etc/ganeti/instance-debootstrap/hooks
+ doins examples/hooks/*
+}
diff --git a/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.9.ebuild b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.9.ebuild
new file mode 100644
index 000000000000..49cfe2508b71
--- /dev/null
+++ b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Scripts to build Ganeti VMs with debootstrap"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/ganeti-instance-debootstrap-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/dpkg
+ app-arch/dump
+ app-emulation/ganeti
+ dev-util/debootstrap
+ >=sys-apps/coreutils-6.10-r1
+ sys-apps/util-linux
+ sys-fs/e2fsprogs"
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${P} || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ insinto /etc/ganeti/instance-debootstrap/hooks
+ doins examples/hooks/*
+}
diff --git a/app-emulation/ganeti-instance-debootstrap/metadata.xml b/app-emulation/ganeti-instance-debootstrap/metadata.xml
new file mode 100644
index 000000000000..2ea2a30d3f47
--- /dev/null
+++ b/app-emulation/ganeti-instance-debootstrap/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>virtualization</herd>
+ <longdescription lang="en">This is a guest OS definition for Ganeti (http://code.google.com/p/ganeti).
+ It will install a minimal version of Debian or Ubuntu via debootstrap (thus
+ it requires network access). This only works if you have a Debian-based node
+ or you have debootstrap installed by hand on another distribution.</longdescription>
+ <upstream>
+ <remote-id type="google-code">ganeti</remote-id>
+ </upstream>
+</pkgmetadata>