summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-03 15:22:50 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-03 15:23:08 -0500
commitb127bce894a33a58670ffbb0f4516e0bd624f2c7 (patch)
treed0fe2870b0e8d122cd44a83c8a48fecce6ed8b43 /app-emulation/glean
parentmail-client/thunderbird: Stabilize 78.3.1 x86, #745432 (diff)
downloadgentoo-b127bce894a33a58670ffbb0f4516e0bd624f2c7.tar.gz
gentoo-b127bce894a33a58670ffbb0f4516e0bd624f2c7.tar.bz2
gentoo-b127bce894a33a58670ffbb0f4516e0bd624f2c7.zip
app-emulation/glean: switch to DISTUTILS_USE_SETUPTOOLS=rdepend
closes: https://bugs.gentoo.org/746281 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation/glean')
-rw-r--r--app-emulation/glean/glean-1.10.3.ebuild5
-rw-r--r--app-emulation/glean/glean-1.17.0.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/app-emulation/glean/glean-1.10.3.ebuild b/app-emulation/glean/glean-1.10.3.ebuild
index db1ffac942b3..939e686bb3b4 100644
--- a/app-emulation/glean/glean-1.10.3.ebuild
+++ b/app-emulation/glean/glean-1.10.3.ebuild
@@ -4,6 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python3_6 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -16,9 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/pbr[${PYTHON_USEDEP}]"
+DEPEND="dev-python/pbr[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
src_install() {
diff --git a/app-emulation/glean/glean-1.17.0.ebuild b/app-emulation/glean/glean-1.17.0.ebuild
index 521c8d3efe66..13ba0b43ea39 100644
--- a/app-emulation/glean/glean-1.17.0.ebuild
+++ b/app-emulation/glean/glean-1.17.0.ebuild
@@ -4,6 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -16,9 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/pbr[${PYTHON_USEDEP}]"
+DEPEND="dev-python/pbr[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
src_install() {