summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-01-19 13:32:16 +0000
committerMarek Szuba <marecki@gentoo.org>2021-01-19 13:32:30 +0000
commitb710545bfd9e325a6ec24516864cc422ba41d302 (patch)
treee3d3fe45ac46c9fc7c38544a7e12a0132629921e /app-emulation/protontricks
parentdev-python/pymetar: Add myself as maintainer (diff)
downloadgentoo-b710545bfd9e325a6ec24516864cc422ba41d302.tar.gz
gentoo-b710545bfd9e325a6ec24516864cc422ba41d302.tar.bz2
gentoo-b710545bfd9e325a6ec24516864cc422ba41d302.zip
app-emulation/protontricks: bump to 1.4.3
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-emulation/protontricks')
-rw-r--r--app-emulation/protontricks/Manifest1
-rw-r--r--app-emulation/protontricks/files/protontricks-1.4.3_no-setuptools-scm.patch32
-rw-r--r--app-emulation/protontricks/protontricks-1.4.3.ebuild57
3 files changed, 90 insertions, 0 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index afc7360b5036..d8eb5a72e40a 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1,2 +1,3 @@
DIST protontricks-1.4.1.tar.gz 31838 BLAKE2B b8c94a1b96fa7df14eaf1cc6d11cb96e43ae4e8c7bd232687a50cae9c79cf2d0e7864b1af0e1dc4cc20086952e1fcefeb16cb71a9c3a977f6feafad1b17d6857 SHA512 7635c9830afa3c64617514cd86edc7d7f9f33e6e81a1da995ec8bee70adc1cf8b5d9de92036c372134e408d735615b267b46a9afc9246f14ff161cb2ee1fc8f9
DIST protontricks-1.4.2.gh.tar.gz 41381 BLAKE2B 9030c5cc0781303834af3b478e78f9ba43f01c68c5e203df20a9db80492dd5e641134b796158011a15e65f6907f27a67c542323ea8f9e10c49dca3f5c663458a SHA512 8b60233723130e5f7cd1a7ce7b9563ba1cc8595352b6d942d9ce66a6906f18d86cf97e2b49cbdb8e276fad6cd038eaf1de8a704a8b900b29de5dfb7327b045d0
+DIST protontricks-1.4.3.tar.gz 43573 BLAKE2B 3a3050ba6e940182d81d98498a5558433ceaa4282f5a23fb93b3cfc299699381493eb2912c5f03bb6a8092be5c50b94bf7181208cda3d4c0f4c90c0f438f7f1b SHA512 7ca8c7c273d92f7c4526caaa8c9db6988c642913c33c6b6188d285d5cfbe30924533a9f024135865cdc1a25bd867ac00bd915b0a61417d17fe0e5ee451417e64
diff --git a/app-emulation/protontricks/files/protontricks-1.4.3_no-setuptools-scm.patch b/app-emulation/protontricks/files/protontricks-1.4.3_no-setuptools-scm.patch
new file mode 100644
index 000000000000..e8c6d75036b8
--- /dev/null
+++ b/app-emulation/protontricks/files/protontricks-1.4.3_no-setuptools-scm.patch
@@ -0,0 +1,32 @@
+Since version 1.4.1 upstream has used setuptools-scm to determine the
+current version number. Unfortunately the package in question does not
+support GitHub release archives, using GitHub VCS snapshots would require
+retrieving and updating commit hashes corresponding to release tags, and
+PyPI tarballs do not contain tests. setuptools_scm_git_archive does not
+help because it requires extra files to be included in the repository,
+which upstream has not done.
+
+Seeing as we already know the version number, bypass setuptools_scm
+altogether and create the version file ourselves. For obvious reasons the
+latter has to be done in ebuilds themselves.
+
+--- a/setup.py
++++ b/setup.py
+@@ -16,9 +16,6 @@
+
+ setup(
+ name="protontricks",
+- use_scm_version={
+- "write_to": "src/protontricks/_version.py"
+- },
+ description=DESCRIPTION,
+ long_description=LONG_DESCRIPTION,
+ author=AUTHOR,
+@@ -28,7 +25,6 @@
+ packages=["protontricks"],
+ package_data={"": ["LICENSE"]},
+ package_dir={"protontricks": "src/protontricks"},
+- setup_requires=["setuptools_scm"],
+ install_requires=["vdf>=3.2"],
+ entry_points={
+ "console_scripts": [
diff --git a/app-emulation/protontricks/protontricks-1.4.3.ebuild b/app-emulation/protontricks/protontricks-1.4.3.ebuild
new file mode 100644
index 000000000000..001bbbfa4688
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.4.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+SRC_URI="https://github.com/Matoking/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.3_no-setuptools-scm.patch
+)
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ echo "version = '${PV}'" > "${S}"/src/${PN}/_version.py || die "Failed to generate the version file"
+}
+
+pkg_postinst() {
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}