summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-01 16:19:21 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-01 16:34:37 +0100
commitc99431391d09e35037fe52bbe7a6d2803e38936a (patch)
tree61e1ac34c03697055fba1b130f860f2fc0f03875 /app-emulation/protontricks
parentapp-emulation/protontricks: drop 1.8.2 (diff)
downloadgentoo-c99431391d09e35037fe52bbe7a6d2803e38936a.tar.gz
gentoo-c99431391d09e35037fe52bbe7a6d2803e38936a.tar.bz2
gentoo-c99431391d09e35037fe52bbe7a6d2803e38936a.zip
app-emulation/protontricks: add 1.9.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-emulation/protontricks')
-rw-r--r--app-emulation/protontricks/Manifest1
-rw-r--r--app-emulation/protontricks/protontricks-1.9.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index d6b7225d8dfa..e5bdbab14967 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1 +1,2 @@
DIST protontricks-1.9.0.tar.gz 154202 BLAKE2B e998bd899ec953ed7ee0bb0f3944da0212b71f2d0eef6c6996040e4d9c607f7bc73b52df4cbc6a70480b308473fa8c0978415a6202f498247bf91662761adf5c SHA512 43ffd2a5cd4d58c44696a2a66da0223a93d553822fdc92a476c661d69f7522d2aef12787bfc33610751bc1171fb1a3da169e3d40a2b60863a9f37ed205771835
+DIST protontricks-1.9.1.tar.gz 158292 BLAKE2B 0825fb03bb05604482c893e7dc399bf0223d76a29eff86f0dd407d89cc8f5b39e8fcfec752a2979a3127921dbdb6dc3d186cc61b53f96c544e9b1526ec5e2246 SHA512 85ab3b1f3d5ff73eee7a8bae2021409443e2f82414f42cfa03646415e53a76e0b853ff1a99cb2d5eed512833ac7a60a2718095161aa56864ca83fe9901786881
diff --git a/app-emulation/protontricks/protontricks-1.9.1.ebuild b/app-emulation/protontricks/protontricks-1.9.1.ebuild
new file mode 100644
index 000000000000..d33c17e8e46a
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.9.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+')"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ echo "version = '${PV}'" > "${S}"/src/${PN}/_version.py || die "Failed to generate the version file"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}