summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-08-24 00:23:38 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-08-24 15:07:51 -0400
commitba956c8e2dcedd1265a19432fc38297c4d6e2e8c (patch)
treeb389742af7edf4cf6ee597f2693c91ec4da560bc /app-emulation/wine/wine-1.8-r3.ebuild
parentapp-emulation/wine: bump to 1.9.17 (diff)
downloadgentoo-ba956c8e2dcedd1265a19432fc38297c4d6e2e8c.tar.gz
gentoo-ba956c8e2dcedd1265a19432fc38297c4d6e2e8c.tar.bz2
gentoo-ba956c8e2dcedd1265a19432fc38297c4d6e2e8c.zip
app-emulation/wine: Fix use of env vars for 9999
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-emulation/wine/wine-1.8-r3.ebuild')
-rw-r--r--app-emulation/wine/wine-1.8-r3.ebuild34
1 files changed, 28 insertions, 6 deletions
diff --git a/app-emulation/wine/wine-1.8-r3.ebuild b/app-emulation/wine/wine-1.8-r3.ebuild
index ad22c0939c77..14de6adcb3d9 100644
--- a/app-emulation/wine/wine-1.8-r3.ebuild
+++ b/app-emulation/wine/wine-1.8-r3.ebuild
@@ -246,6 +246,27 @@ wine_build_environment_check() {
fi
}
+wine_env_vcs_vars() {
+ local pn_live_var="${PN//[-+]/_}_LIVE_COMMIT"
+ local pn_live_val="${pn_live_var}"
+ eval pn_live_val='$'${pn_live_val}
+ if [[ ! -z ${pn_live_val} ]]; then
+ if use staging || use d3d9; then
+ eerror "Because of the multi-repo nature of ${PN}, ${pn_live_var}"
+ eerror "cannot be used to set the commit. Instead, you may use the"
+ eerror "environmental variables WINE_COMMIT, STAGING_COMMIT, and D3D9_COMMIT."
+ eerror
+ return 1
+ fi
+ fi
+ if [[ ! -z ${EGIT_COMMIT} ]]; then
+ eerror "Commits must now be specified using the environmental variables"
+ eerror "WINE_COMMIT, STAGING_COMMIT, and D3D9_COMMIT"
+ eerror
+ return 1
+ fi
+}
+
pkg_pretend() {
wine_compiler_check || die
wine_build_environment_check || die
@@ -263,6 +284,7 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
+ wine_env_vcs_vars || die
if ! use staging; then
GV=${VANILLA_GV}
MV=${VANILLA_MV}
@@ -274,19 +296,19 @@ pkg_setup() {
src_unpack() {
if [[ ${PV} == "9999" ]] ; then
- git-r3_src_unpack
+ EGIT_COMMIT="${WINE_COMMIT}" git-r3_src_unpack
if use staging; then
- local WINE_COMMIT=${EGIT_VERSION}
+ local CURRENT_WINE_COMMIT=${EGIT_VERSION}
- git-r3_fetch "${STAGING_EGIT_REPO_URI}"
+ git-r3_fetch "${STAGING_EGIT_REPO_URI}" "${STAGING_COMMIT}"
git-r3_checkout "${STAGING_EGIT_REPO_URI}" "${STAGING_DIR}"
- local STAGING_COMMIT=$("${STAGING_DIR}/patches/patchinstall.sh" --upstream-commit) || die
+ local COMPAT_WINE_COMMIT=$("${STAGING_DIR}/patches/patchinstall.sh" --upstream-commit) || die
- if [[ "${WINE_COMMIT}" != "${STAGING_COMMIT}" ]]; then
+ if [[ "${CURRENT_WINE_COMMIT}" != "${COMPAT_WINE_COMMIT}" ]]; then
einfo "The current Staging patchset is not guaranteed to apply on this WINE commit."
einfo "If src_prepare fails, try emerging with the env var EGIT_COMMIT."
- einfo "Example: EGIT_COMMIT=${STAGING_COMMIT} emerge -1 wine"
+ einfo "Example: WINE_COMMIT=${COMPAT_WINE_COMMIT} emerge -1 wine"
fi
fi
fi