summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-03-19 11:06:08 -0500
committerMatthias Maier <tamiko@gentoo.org>2018-03-19 11:09:45 -0500
commit2209aa7d8367d86752cd4c059b25951f4a20c597 (patch)
tree66a194506a581774b519daed6923152dd5b10e11 /app-emulation
parentdev-python/pyx: fix a LaTeX problem with USE=doc (diff)
downloadgentoo-2209aa7d8367d86752cd4c059b25951f4a20c597.tar.gz
gentoo-2209aa7d8367d86752cd4c059b25951f4a20c597.tar.bz2
gentoo-2209aa7d8367d86752cd4c059b25951f4a20c597.zip
app-emulation/spice-vdagent: version bump to 0.17.0_p20180319
Bug: https://bugs.gentoo.org/650020 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spice-vdagent/Manifest1
-rw-r--r--app-emulation/spice-vdagent/spice-vdagent-0.17.0_p20180319.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-emulation/spice-vdagent/Manifest b/app-emulation/spice-vdagent/Manifest
index 490424d6b3b0..136c9215aacf 100644
--- a/app-emulation/spice-vdagent/Manifest
+++ b/app-emulation/spice-vdagent/Manifest
@@ -1 +1,2 @@
+DIST spice-vdagent-0.17.0-patches-20180319.tar.xz 38924 BLAKE2B c7c7f851d307cd7dde620278c6ea240d71f8b1f25d6367f81213c7e902d2b2c15f72c71344f965743a45b5693832a2937041ca7b5511ce1db479dafe137bc7b1 SHA512 8ac627f56605151aebc100a6c6d61243776662150095c768196d750929971f98f4b6d1a831cfb547d29ae8a6734795c93e51a9c4f27dcf53bd66aca6df437c51
DIST spice-vdagent-0.17.0.tar.bz2 130413 BLAKE2B b2fb522f491512d94ac15fa8d253e8e682210ad40657eb9e5e40489eaab18c9f1d5ef5f97075a4389501050a758e1f56d47132de6b1c74bb153fc6b5e87a698d SHA512 b26e44f6463ba70d5815956b301cc2351db22de41ed2ce8b2828d9bfa1cc581c86acd433f8f0d35d552d20f6ca140f88fa39b079ba26e9166dc07ad35bee502e
diff --git a/app-emulation/spice-vdagent/spice-vdagent-0.17.0_p20180319.ebuild b/app-emulation/spice-vdagent/spice-vdagent-0.17.0_p20180319.ebuild
new file mode 100644
index 000000000000..a7df7047bde6
--- /dev/null
+++ b/app-emulation/spice-vdagent/spice-vdagent-0.17.0_p20180319.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info
+
+MY_P="${P/_*/}"
+PATCHSET="${P/*_p/}"
+
+DESCRIPTION="SPICE VD Linux Guest Agent"
+HOMEPAGE="https://www.spice-space.org/"
+SRC_URI="https://www.spice-space.org/download/releases/${MY_P}.tar.bz2
+ https://dev.gentoo.org/~tamiko/distfiles/${MY_P}-patches-${PATCHSET}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+consolekit selinux systemd"
+S="${WORKDIR}/${MY_P}"
+
+CDEPEND="
+ >=app-emulation/spice-protocol-0.12.8
+ media-libs/alsa-lib
+ >=x11-libs/libpciaccess-0.10
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libX11
+ x11-libs/libXinerama
+ consolekit? ( sys-auth/consolekit sys-apps/dbus )
+ systemd? ( sys-apps/systemd )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-vdagent )"
+
+CONFIG_CHECK="~INPUT_UINPUT ~VIRTIO_CONSOLE"
+ERROR_INPUT_UINPUT="User level input support (INPUT_UINPUT) is required"
+ERROR_VIRTIO_CONSOLE="VirtIO console/serial device support (VIRTIO_CONSOLE) is required"
+
+PATCHES=(
+ "${WORKDIR}"/patches
+ )
+
+src_configure() {
+ local opt=()
+ if use consolekit; then
+ opt+=( --with-session-info=console-kit )
+ elif use systemd; then
+ opt+=( --with-session-info=systemd )
+ else
+ opt+=( --with-session-info=none )
+ fi
+
+ econf \
+ --with-init-script=systemd \
+ --localstatedir="${EPREFIX}"/var \
+ "${opt[@]}"
+}
+
+src_install() {
+ default
+
+ cd "${ED}" && rmdir -p var/run/spice-vdagentd || die
+
+ keepdir /var/log/spice-vdagentd
+
+ newinitd "${FILESDIR}/${PN}.initd-3" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd-2" "${PN}"
+}