summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2016-07-25 16:39:48 +0300
committerNP-Hardass <NP-Hardass@gentoo.org>2016-07-29 00:48:51 -0400
commit35d9cc7a46214dd79d579a3f9a77581b6893424a (patch)
tree4d975e24b318c5352be03dc7b3871410d5f8694d /app-emulation
parentgames-puzzle/sgt-puzzles: Drop old (diff)
downloadgentoo-35d9cc7a46214dd79d579a3f9a77581b6893424a.tar.gz
gentoo-35d9cc7a46214dd79d579a3f9a77581b6893424a.tar.bz2
gentoo-35d9cc7a46214dd79d579a3f9a77581b6893424a.zip
app-emulation/winetricks: Version bump to 20160724.
Package-Manager: portage-2.3.0 Signed-off-by: NP-Hardass <NP-Hardass@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/winetricks/Manifest1
-rw-r--r--app-emulation/winetricks/winetricks-20160724.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/app-emulation/winetricks/Manifest b/app-emulation/winetricks/Manifest
index baed78ac081f..63f3fdfc1334 100644
--- a/app-emulation/winetricks/Manifest
+++ b/app-emulation/winetricks/Manifest
@@ -1,2 +1,3 @@
DIST winetricks-20160709.tar.gz 173713 SHA256 c21a7bb4c312eeea27325d82160fee5e6961387fd396540d78d57a590df1ebe5 SHA512 8624cb8c1152f637fb46f66035059e6832e5d083e2df6737d8e6ec5a5981dc2650e1160ad3de04ab120e971a2f9a7df906f10fe95951db258217f6f0774d5b84 WHIRLPOOL 305b64049670d01fd8f3544b38033df10e11d49e2033c65688d9eddeda305f51cdfa5aeded05bda3a4239105ad03f071aa785eac200f61da2581c406db3c43d6
+DIST winetricks-20160724.tar.gz 173873 SHA256 dbacdbc241a2bc55b0174ff06f828528bbc2bbf0a0d15c077f75d2f6acda8186 SHA512 ae94b5f039ab4109e40bfb0ee94c100c1f7573ec34dcc4f6d10094a4d5e27ada38e77343c912034c973c0b4dd55f66a31b8be6c75075681f4bd503c3751c0494 WHIRLPOOL c7c8bcc4f29eb757d0b12f528c74d6e1faa4590cda8a844d7c43047bda52f6ef0b081c6e5eb87854f050cd9c96889069586c79e549bd4324e8b8ca930b2b7815
DIST winetricks-gentoo-2012.11.24.tar.bz2 6398 SHA256 dded8c294cc5c2e71e4a5d1531ab165178cf3d2d1d890d0656368c2e499bfeb9 SHA512 59c93b73f3a7b2d11aefcde2ff66659ff1de21ad4b5f232f4b60572f3a48b15a6c49f369b1696862bf1b33fde190bf5598945e9536fb41ddec42d8def4d2be2a WHIRLPOOL 268da9e06712a678fbbcfff8eac1fca364b5e46f0a9c48a591eb88f03260b1a55f203eb2908bfe1f0a534b77c866127ff6f7049b0e43fe8abeaaa26fe55de75b
diff --git a/app-emulation/winetricks/winetricks-20160724.ebuild b/app-emulation/winetricks/winetricks-20160724.ebuild
new file mode 100644
index 000000000000..b8aef92710f5
--- /dev/null
+++ b/app-emulation/winetricks/winetricks-20160724.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit gnome2-utils eutils
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Winetricks/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Winetricks/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+wtg=winetricks-gentoo-2012.11.24
+
+SRC_URI="${SRC_URI}
+ gtk? ( https://dev.gentoo.org/~tetromino/distfiles/wine/${wtg}.tar.bz2 )
+ kde? ( https://dev.gentoo.org/~tetromino/distfiles/wine/${wtg}.tar.bz2 )"
+
+DESCRIPTION="Easy way to install DLLs needed to work around problems in Wine"
+HOMEPAGE="http://winetricks.org http://wiki.winehq.org/winetricks"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="gtk kde rar"
+
+DEPEND=""
+RDEPEND="app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ app-emulation/wine
+ net-misc/wget
+ x11-misc/xdg-utils
+ gtk? ( gnome-extra/zenity )
+ kde? ( kde-apps/kdialog )
+ rar? ( app-arch/unrar )"
+
+# Uses a non-standard "Wine" category, which is provided by app-emulation/wine; #451552
+QA_DESKTOP_FILE="usr/share/applications/winetricks.desktop"
+
+# Tests require network access and run Wine, which is unreliable from a portage environment.
+RESTRICT="test"
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git-r3_src_unpack
+ if use gtk || use kde; then
+ unpack ${wtg}.tar.bz2
+ fi
+ else
+ default
+ fi
+}
+
+src_install() {
+ default
+ if use gtk || use kde; then
+ cd "${WORKDIR}/${wtg}" || die
+ domenu winetricks.desktop
+ insinto /usr/share/icons/hicolor/scalable/apps
+ doins wine-winetricks.svg
+ fi
+}
+
+pkg_preinst() {
+ if use gtk || use kde; then
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use gtk || use kde; then
+ gnome2_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk || use kde; then
+ gnome2_icon_cache_update
+ fi
+}