summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2016-01-21 08:27:44 +0100
committerWolfram Schlich <wschlich@gentoo.org>2016-01-21 08:28:07 +0100
commit4b992ca12f07e4f22fe8c65cfe7b886bd6ffe54a (patch)
tree6a6c17381ffa27cbedca0f5c2080d764009a779f /app-emulation
parentdev-ruby/webmock: added Prefix keywords, bug #563858 (diff)
downloadgentoo-4b992ca12f07e4f22fe8c65cfe7b886bd6ffe54a.tar.gz
gentoo-4b992ca12f07e4f22fe8c65cfe7b886bd6ffe54a.tar.bz2
gentoo-4b992ca12f07e4f22fe8c65cfe7b886bd6ffe54a.zip
added q4wine-1.2_p2
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/q4wine/Manifest1
-rw-r--r--app-emulation/q4wine/q4wine-1.2_p2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-emulation/q4wine/Manifest b/app-emulation/q4wine/Manifest
index f203be4b98c5..5dbb9f050153 100644
--- a/app-emulation/q4wine/Manifest
+++ b/app-emulation/q4wine/Manifest
@@ -1,2 +1,3 @@
DIST q4wine-1.0-r3.tar.bz2 889308 SHA256 9f1319dd0baff3834a3938e0a048c1529cb9ea521158370176b706fce0d4d2ff SHA512 df10a2fbf6874f4c4e02dd9c43031453a46c76f03d83321f2d6e9544d0540dd07da1bc9246767c5c91ce17d67d5d236227294efaed9de09f3d5a18afbd60b224 WHIRLPOOL 51b5b4cfc157da6b99154269ef4ef9f38ff91f861864158b789352505af485d8b523a21c6d4b59544804ed3c15cb1c6c756db3f3203c8e3ba55c8396c3630df3
DIST q4wine-1.1-r2.tar.bz2 888990 SHA256 01463f9ec3ef9f7ef987d2b77425f2806cf2b60f574deb6644458366782eafc7 SHA512 8aaeec46d239a86a9eb10377842d63d84a35864f920f9dc46a022ae1cf3e010273d3759701595e058a089f6418a297a0bf94ed62b580a71fa1c8c27a80f4ec7e WHIRLPOOL 6ae891e33a2bf3759c45930820e21a273b2bf36f2c386a841a96c3bf14cfdb6741871d3c90383dde3b6b01df1a87f5b1537ae40bac5a494bdd3023248c526244
+DIST q4wine-1.2-r2.tar.bz2 690922 SHA256 44bac78060233504d0db945533e5da4a92bf8b4ca4ef87928032d14451e42160 SHA512 c47fc3adc756ea4bc33dc10f6de03e0a0e72258d1b4b238930136653a7938869d221ce08f6fcafcd5f012583b28227cf827505a59ee5322e9ab90c2c819fd7cb WHIRLPOOL 564eb944097528248f340ac59462f63bec22211d554ad26f125d46382a30ee2a8b7c8d00dd8874fabe92ae939f6bcf13665158957e0e8dad26e077018e495c0d
diff --git a/app-emulation/q4wine/q4wine-1.2_p2.ebuild b/app-emulation/q4wine/q4wine-1.2_p2.ebuild
new file mode 100644
index 000000000000..686546e9b44d
--- /dev/null
+++ b/app-emulation/q4wine/q4wine-1.2_p2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PLOCALES="af_ZA cs_CZ de_DE en_US es_ES fa_IR he_IL it_IT pl_PL pt_BR ru_RU uk_UA"
+PLOCALE_BACKUP="en_US"
+
+inherit cmake-utils l10n
+
+DESCRIPTION="Qt4 GUI configuration tool for Wine"
+HOMEPAGE="http://q4wine.brezblock.org.ua/"
+
+# Upstream names the package PV-rX. We change that to
+# PV_pX so we can use portage revisions.
+MY_PV="${PV/_p/-r}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PN}%20${MY_PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dbus debug +icoutils +wineappdb"
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsingleapplication[qt4(+),X]
+ dev-qt/qtsql:4[sqlite]
+ dbus? ( dev-qt/qtdbus:4 )
+"
+RDEPEND="${DEPEND}
+ app-admin/sudo
+ app-emulation/wine
+ >=sys-apps/which-2.19
+ sys-fs/fuseiso
+ icoutils? ( >=media-gfx/icoutils-0.26.0 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ local enabled_linguas
+ construct_LINGUAS() {
+ local current_locale="$(echo ${1} | tr '[:upper:]' '[:lower:]')"
+ enabled_linguas="${enabled_linguas};${current_locale}"
+ }
+ l10n_for_each_locale_do construct_LINGUAS
+ local mycmakeargs=(
+ -DLINGUAS="${enabled_linguas}"
+ -DQT5=OFF
+ -DWITH_SYSTEM_SINGLEAPP=ON
+ $(cmake-utils_use debug)
+ $(cmake-utils_use_with dbus)
+ $(cmake-utils_use_with icoutils)
+ $(cmake-utils_use_with wineappdb)
+ )
+ cmake-utils_src_configure
+}