summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-10-31 18:57:07 +0100
committerSebastian Pipping <sping@gentoo.org>2018-10-31 18:58:45 +0100
commit53e4fdb64cdd2662c153d0f3769e402f8996ee3b (patch)
tree993baaa48ec3300342f4a629addc61f250a96d55 /app-emulation
parentdev-python/colorama: 0.4.0 (diff)
downloadgentoo-53e4fdb64cdd2662c153d0f3769e402f8996ee3b.tar.gz
gentoo-53e4fdb64cdd2662c153d0f3769e402f8996ee3b.tar.bz2
gentoo-53e4fdb64cdd2662c153d0f3769e402f8996ee3b.zip
app-emulation/docker-compose: 1.23.0
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.23.0.ebuild73
-rw-r--r--app-emulation/docker-compose/files/docker-compose-1.23.0-setup-py.patch59
3 files changed, 133 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index 25a210d5bfcc..bc123b2ca6d7 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -1,3 +1,4 @@
DIST docker-compose-1.19.0.tar.gz 238307 BLAKE2B 2a7bbcf50c2cc591eba1d59db30cb0341e33e3f1ebe948e0b6762d9bffcdcc72d98e2da19fc549c5fabda192fca69a9d54e016601ddb4f4a94f0dc1c93f99a29 SHA512 f1d522621580a5130378508e6b15ad2e4708e9c5ff713627ca54308ab3e6bf000e21c55bbdf9585b2116e73648fdc773500a5415ab81a72dd2c69c9c07e71581
DIST docker-compose-1.21.2.tar.gz 294070 BLAKE2B c27ce8708f20385ee3f072c4aa832a42dc975d08d71d9e61ce3a822055d606db7e1e7b6e182523e64115922416d5c1baeca14897a241e84873a97aa755bce539 SHA512 6392582d8c6c321458b1163336f1c902548cc250f9ab5b765d144287b006ef6dacdc47199fafbb6efe426e382325b94986aa159df08dec4974a71968862a8435
DIST docker-compose-1.22.0.tar.gz 296747 BLAKE2B 9dfd25fb186436801d9c12900c4103c1c0d83bee3b424b3f2373247aeeb8261fed04cf9be9cee230a48e1c19523b48d5618a18f322c236bac1d769036f9ac979 SHA512 eccef2165221fcfdac089ffd3bd0795d08d8c6f7158709dbc2fc83a6d6e9466af4b73c0c7d24a751c6b546b4219e10dfc96cd41e13e7ebc676da603c97b7620e
+DIST docker-compose-1.23.0.tar.gz 302110 BLAKE2B 0239d787a383c983d9965cecb087ff8d3050cd98bba0c324ea8f12f062f1b582fcfb20498d0cd0e323fe0912439f6ba288798f5c3d83e3c6a77fb298225fdf3a SHA512 b22f4c76e4187e9a01186516bbfaf988e9fc3e74e7a8455b6424cec61572a621d82f7bec9e23188fa297da26b0777c83d01374a628575d73fbb95502fb27d2db
diff --git a/app-emulation/docker-compose/docker-compose-1.23.0.ebuild b/app-emulation/docker-compose/docker-compose-1.23.0.ebuild
new file mode 100644
index 000000000000..504a8d4449a9
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.23.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit bash-completion-r1 distutils-r1 vcs-snapshot
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://github.com/docker/compose"
+SRC_URI="https://github.com/docker/compose/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
+ !~dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.9[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ ${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
+ )
+"
+RDEPEND="${CDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-setup-py.patch
+)
+
+src_prepare() {
+ # Address QA issue "docker-compose.exe: missing alias (symlink) for completed command."
+ sed 's,^\(complete.*\) docker-compose\.exe\(.*\),\1\2,' -i contrib/completion/bash/docker-compose || die
+
+ default
+}
+
+python_test() {
+ ${PYTHON} -m pytest tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}
diff --git a/app-emulation/docker-compose/files/docker-compose-1.23.0-setup-py.patch b/app-emulation/docker-compose/files/docker-compose-1.23.0-setup-py.patch
new file mode 100644
index 000000000000..c95c776b2c38
--- /dev/null
+++ b/app-emulation/docker-compose/files/docker-compose-1.23.0-setup-py.patch
@@ -0,0 +1,59 @@
+From c481f53ff75d015b4db37b294c5a2142d0272f32 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Wed, 31 Oct 2018 18:45:59 +0100
+Subject: [PATCH] setup.py: Drop generic upper version boundaries
+
+---
+ setup.py | 28 ++++++++++++++--------------
+ 1 file changed, 14 insertions(+), 14 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 8260ebc..7f76abb 100644
+--- a/setup.py
++++ b/setup.py
+@@ -30,16 +30,16 @@ def find_version(*file_paths):
+
+
+ install_requires = [
+- 'cached-property >= 1.2.0, < 2',
+- 'docopt >= 0.6.1, < 0.7',
+- 'PyYAML >= 3.10, < 4',
+- 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0, < 2.21',
+- 'texttable >= 0.9.0, < 0.10',
+- 'websocket-client >= 0.32.0, < 1.0',
+- 'docker >= 3.5.0, < 4.0',
+- 'dockerpty >= 0.4.1, < 0.5',
+- 'six >= 1.3.0, < 2',
+- 'jsonschema >= 2.5.1, < 3',
++ 'cached-property >= 1.2.0',
++ 'docopt >= 0.6.1',
++ 'PyYAML >= 3.10',
++ 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0',
++ 'texttable >= 0.9.0',
++ 'websocket-client >= 0.32.0',
++ 'docker >= 3.5.0',
++ 'dockerpty >= 0.4.1',
++ 'six >= 1.3.0',
++ 'jsonschema >= 2.5.1',
+ ]
+
+
+@@ -52,11 +52,11 @@ if sys.version_info[:2] < (3, 4):
+ tests_require.append('mock >= 1.0.1')
+
+ extras_require = {
+- ':python_version < "3.4"': ['enum34 >= 1.0.4, < 2'],
++ ':python_version < "3.4"': ['enum34 >= 1.0.4'],
+ ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'],
+- ':python_version < "3.3"': ['ipaddress >= 1.0.16'],
+- ':sys_platform == "win32"': ['colorama >= 0.4, < 0.5'],
+- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
++ ':python_version < "3.3"': ['ipaddress'],
++ ':sys_platform == "win32"': ['colorama >= 0.4'],
++ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
+ }
+
+
+--
+2.19.1
+