summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-04-22 01:31:23 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-04-22 01:31:23 +0200
commit70a12c693102476d007dbca676247ad188be88ef (patch)
tree0ee7ea78f45ef1d058b9df328b1ab78b780318b4 /app-emulation
parentdev-python/certifi: Version bump to 2018.1.18 (diff)
downloadgentoo-70a12c693102476d007dbca676247ad188be88ef.tar.gz
gentoo-70a12c693102476d007dbca676247ad188be88ef.tar.bz2
gentoo-70a12c693102476d007dbca676247ad188be88ef.zip
app-emulation/kompose: Version bump to 1.12.0
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/kompose/Manifest1
-rw-r--r--app-emulation/kompose/kompose-1.12.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/kompose/Manifest b/app-emulation/kompose/Manifest
index 10ba99521516..62a0b5a182b7 100644
--- a/app-emulation/kompose/Manifest
+++ b/app-emulation/kompose/Manifest
@@ -1,2 +1,3 @@
DIST kompose-1.10.0.tar.gz 5232838 BLAKE2B 145938e68ede3f956cf0a2c08066ec49257527357c1c032d265b39fc00f4c07da26fcc90f1e8999a755345715332dfb5f6df82f15e817c8460f2c9038ebbc1a5 SHA512 578348c5907344b47bac17b9d6a9d8c4ba5cce9fbe72ad3b65af60dcfb985bd39ee2973308dbfa45d4bd78467fa330621c16624cc7d92287b943ac02d0ae3e45
DIST kompose-1.11.0.tar.gz 5233209 BLAKE2B 335281a1d311a41ef288236bc6796c2f8a70c7dfb7fc131f8baaaa845597f24c3e8200a67fad0d893f8f0da6f21c0eb6fc7fd416634e78cdd0212390ae814f26 SHA512 635297df08a6af107949bd39d3f8fb1a00eb1c1b7584b1f1e451a291df657709fb0998d155d6f4a6c12e3b716a7a8194eac57f654d8ad3f8f8f9b91011398aaa
+DIST kompose-1.12.0.tar.gz 5234150 BLAKE2B 0b046cc2fb9420a69bb8a2d82a7c4f8a62db74acfaa9cdc5dc16b3710cda7c03fb43651bdd1e43281502f4aa181b50168120375a7f0e298a1ba018ddb94cd43a SHA512 5467b8fa54fe9368f1f1627c04e4edab597822b7b2c3c101510379cceac8ca92e24540b81b82e947244b1b4056e2b1a5806220b38bbe5db5965c3f7aeff908ef
diff --git a/app-emulation/kompose/kompose-1.12.0.ebuild b/app-emulation/kompose/kompose-1.12.0.ebuild
new file mode 100644
index 000000000000..b2b9a62edf3b
--- /dev/null
+++ b/app-emulation/kompose/kompose-1.12.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/kubernetes/kompose"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="0ab07be"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Tool to move from docker-compose to Kubernetes"
+HOMEPAGE="https://github.com/kubernetes/kompose https://kompose.io"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+
+RESTRICT="test"
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ GOPATH="${S}" go build -v -ldflags="-X github.com/kubernetes/kompose/cmd.GITCOMMIT=${GIT_COMMIT}" -o bin/kompose src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{docs,{README,RELEASE,ROADMAP,CHANGELOG,CONTRIBUTING}.md}
+}